Bug 496767 - spamass-milter generates false positives for authenticated users.
spamass-milter generates false positives for authenticated users.
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: spamass-milter (Show other bugs)
10
All Linux
low Severity high
: ---
: ---
Assigned To: Paul Howarth
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-20 22:41 EDT by Habeeb J. Dihu
Modified: 2009-10-27 03:20 EDT (History)
2 users (show)

See Also:
Fixed In Version: 0.3.1-14.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-27 02:30:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Add an option to spamass-milter to bypass checks for authenticated users. (3.47 KB, patch)
2009-04-20 22:41 EDT, Habeeb J. Dihu
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Debian BTS 301755 None None None Never

  None (edit)
Description Habeeb J. Dihu 2009-04-20 22:41:16 EDT
Created attachment 340469 [details]
Add an option to spamass-milter to bypass checks for authenticated users.

spamass-milter generates false positives for authenticated users when email is being sent, in part because of the way it generates Received headers.  Authenticated users (authenticated via SMTP AUTH) are presumably trusted.  This adds an option to enable that desired functionality.  With the -I flag, authenticated users bypass SpamAssassin entirely.  Based on the Debian patch to do the same thing.

I'd love to see this patch incorporated into the upstream -- it reduces load on our servers by avoiding unnecessary SpamAssassin calls and solves the problem of having an authenticated user's email being potentially marked as spam.
Comment 1 Fedora Update System 2009-04-24 16:01:27 EDT
spamass-milter-0.3.1-14.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/spamass-milter-0.3.1-14.fc11
Comment 2 Fedora Update System 2009-04-24 16:05:01 EDT
spamass-milter-0.3.1-14.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/spamass-milter-0.3.1-14.fc10
Comment 3 Paul Howarth 2009-04-24 16:19:34 EDT
Thanks for the patches. You're not the first to ask for this and I've previously held off doing it because (a) I thought this should go upstream first, and (b) there is I think a better way of achieving the same result, namely run the milter on the MTA port only and have authenticating clients use the submission port (587) instead, where their mail will never even be seen by the milter (this is the approach I use myself).

However, it seems that there's no activity at all upstream and I imagine some users might have difficulty getting their users to use the submission port (even though it's certainly the "right thing to do" as it also avoids outbound smtp blocking that travelling users might come up against when using hotel etc. networks. So I finally gave in and applied the patch. Thanks again, and please do test the package.
Comment 4 Fedora Update System 2009-04-27 17:41:38 EDT
spamass-milter-0.3.1-14.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update spamass-milter'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-4062
Comment 5 Fedora Update System 2009-10-27 02:30:32 EDT
spamass-milter-0.3.1-14.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Fedora Update System 2009-10-27 03:20:38 EDT
spamass-milter-0.3.1-14.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.