Bug 49677 - db2rtf generates an RTF file which has one line per page.
db2rtf generates an RTF file which has one line per page.
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: docbook-utils (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-22 21:21 EDT by Need Real Name
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-13 15:16:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The sample file that demonstrates the problem and the generated RTF (3.59 KB, application/octet-stream)
2001-07-25 01:57 EDT, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2001-07-22 21:21:14 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)

Description of problem:
The db2rtf generates an RTF file that when viewed through microsoft word 
97 shows one line per page.  The db2html and db2pdf are OK.

How reproducible:
Always

Steps to Reproduce:
1.Create a simple book SGML in docbook
2.Run db2rtf on it
3. view the generated RTF in MS Word
	

Additional info:
Comment 1 Tim Waugh 2001-07-23 05:28:47 EDT
Please send me an example SGML document, or we might not be looking at the 
same thing.  Thanks.
Comment 2 Need Real Name 2001-07-25 01:57:09 EDT
Created attachment 24887 [details]
The sample file that demonstrates the problem and the generated RTF
Comment 3 Tim Waugh 2001-07-26 11:31:07 EDT
Thanks.

Okay, I see the same thing with MS-Word 2000.  It isn't something obvious like 
unix2dosifying the file; I tried that.

Do you know when this last worked, or has it always behaved like this?
Comment 4 Need Real Name 2001-07-26 11:53:52 EDT
Actually I am using the db2xxx for the first time.  I have always used 
openjade -t rtf -d .../print/docbook.dsl myfile.sgml to generate the files.  
That still works fine.  The problem seems to be with db2xxx (the associated 
stylesheet I guess)
Comment 5 Tim Waugh 2001-08-03 06:25:05 EDT
Yes.  The stylesheet is /usr/share/sgml/docbook/utils-*/docbook-utils.dsl.

If you copy that file to /tmp/style.dsl and take out the section entitled
'Margins' (lines 175-227), and use db2rtf -d /tmp/style.dsl ..., does that work
any better?
Comment 6 Tim Waugh 2001-08-13 12:19:45 EDT
After some experimentation, it seems that this bit is the problem:

;;How big do you want the margin at the bottom?
(define %bottom-margin%
 (if (equal? %visual-acuity% "large-type")
      7.5pi
      2pi))

If I take that out, it works fine.

Comment 7 David Mason 2001-08-13 12:26:55 EDT
Of course taking that out produces a rather large margin at the bottom of
postscript files :\ - still, better than breakage I suppose.
Comment 8 Tim Waugh 2001-08-13 13:01:27 EDT
But bizarrely, if I change it to 9.5pi/8pi (from print/dbparam.dsl) rather 
than removing it altogether, it _still_ breaks.

Why would that be?
Comment 9 David Mason 2001-08-13 13:08:15 EDT
but if you remove it altogether it should default to what is in
print/dbparam.dsl - are you sure it is not broken without it? Otherwise I would
think that there is a bug in Norman's code which allows for these overrides to
happen. I will ask him about it - we can remove for the release.
Comment 10 Tim Waugh 2001-08-13 14:43:40 EDT
I must have done something wrong before; you're right, there is no difference 
if overridden or not.

Changing the '2pi' to '5pi' is sufficient to fix the problem, so I think I'll 
do that.
Comment 11 David Mason 2001-08-13 15:16:36 EDT
yeah - that looks all right to me
Comment 12 Tim Waugh 2001-08-13 17:45:14 EDT
That change is in docbook-utils-0.6.9-2.

Note You need to log in before you can comment on or make changes to this bug.