Bug 496782 - facebook image upload applet crashes firefox
facebook image upload applet crashes firefox
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: java-1.6.0-openjdk (Show other bugs)
10
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Deepak Bhole
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-21 02:35 EDT by Ian Malone
Modified: 2009-12-18 04:18 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-18 04:18:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
about:plugins (2.21 KB, text/plain)
2009-04-21 17:40 EDT, Ian Malone
no flags Details
java.stdout for ICEDTEAPLUGIN_DEBUG=true (99 bytes, text/plain)
2009-04-28 19:14 EDT, Ian Malone
no flags Details
java.stderr for ICEDTEAPLUGIN_DEBUG=true (37.62 KB, text/plain)
2009-04-28 19:15 EDT, Ian Malone
no flags Details
console output with ICEDTEAPLUGIN_DEBUG=true (18.48 KB, text/plain)
2009-04-28 19:21 EDT, Ian Malone
no flags Details
about:plugins (2.21 KB, text/plain)
2009-06-02 19:44 EDT, Ian Malone
no flags Details

  None (edit)
Description Ian Malone 2009-04-21 02:35:11 EDT
Description of problem:
On selecting the add more photos to album link in Firefox, FF loads the page, displays a grey box where the applet would appear and then crashes while loading.  Additionally if run under the debugger (firefox -g) a certificate verification window appears, but by this time the FF window itself has frozen.  It may possibly appear when run without the debugger, a window appears but closes before anything is drawn in it.

Version-Release number of selected component (if applicable):
java-1.6.0-openjdk-plugin-1.6.0.0-15.b14.fc10.x86_64
java-1.6.0-openjdk-1.6.0.0-15.b14.fc10.x86_64
firefox-3.0.8-1.fc10.x86_64

How reproducible:
100%


Steps to Reproduce:
1. Visit any of your Facebook albums
2. Click on add more photos
3. Crash
  
Actual results:
Photo uploader album loads

Expected results:
Firefox crashes

Additional info:
$ alternatives --config java

There is 3 program that provides 'java'.

  Selection    Command
-----------------------------------------------
   1           /usr/lib/jvm/jre-1.5.0-gcj/bin/java
*  2           /usr/java/default/bin/java
 + 3           /usr/lib/jvm/jre-1.6.0-openjdk.x86_64/bin/java

$ alternatives --config libjavaplugin.so.x86_64

There is 2 program that provides 'libjavaplugin.so.x86_64'.

  Selection    Command
-----------------------------------------------
*  1           /usr/java/jre1.6.0_13/lib/amd64/libnpjp2.so
 + 2           /usr/lib/jvm/jre-1.6.0-openjdk.x86_64/lib/amd64/IcedTeaPlugin.so

Last few lines of $ firefox -g
[New Thread 0x7f2d27ee1950 (LWP 3628)]
[New Thread 0x7f2d274e0950 (LWP 3629)]

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0x7f2d3545b950 (LWP 3613)]
0x0000003f9e64d429 in ?? () from /usr/lib64/xulrunner-1.9/libxul.so
Missing separate debuginfos, use: debuginfo-install alsa-lib-devel-1.0.19-2.fc10.x86_64 avahi-0.6.22-12.fc10.x86_64 avahi-glib-0.6.22-12.fc10.x86_64 bzip2-libs-1.0.5-3.fc10.x86_64 cyrus-sasl-lib-2.1.22-19.fc10.x86_64 gamin-0.1.9-6.fc10.x86_64 gvfs-1.0.3-7.fc10.x86_64 keyutils-libs-1.2-3.fc9.x86_64 krb5-libs-1.6.3-18.fc10.x86_64 libXScrnSaver-1.1.3-1.fc10.x86_64 libacl-2.2.47-3.fc10.x86_64 libattr-2.4.43-2.fc10.x86_64 libcap-2.10-2.fc10.x86_64 libcroco-0.6.1-5.fc9.x86_64 libcurl-7.19.4-3.fc10.x86_64 libgsf-1.14.10-1.fc10.x86_64 libidn-0.6.14-8.x86_64 librsvg2-2.22.3-1.fc10.x86_64 libssh2-0.18-7.fc9.x86_64 nss-mdns-0.10-6.fc10.x86_64 openldap-2.4.12-1.fc10.x86_64 rhythmbox-0.11.6-20.r6096.fc10.x86_64 startup-notification-0.9-4.fc9.x86_64
(gdb) Facebook Photo Uploader 5 version: 5.5.8.0
Current document URL: http://www.facebook.com/editalbum.php?aid=2304901&add=1

Additionally this works under Sun Java 6.0.13.
Comment 1 Deepak Bhole 2009-04-21 09:31:14 EDT
Can you please run 'rpm -qV java-1.6.0-openjdk-plugin' and post if it shows any output? Want to make sure that the version isn't corrupt. 

Also, what does the IcedTea plugin info show when you go to about:plugins in firefox?
Comment 2 Ian Malone 2009-04-21 17:40:53 EDT
Created attachment 340633 [details]
about:plugins

[ian@atlas Desktop]$ rpm -qV java-1.6.0-openjdk-plugin
[ian@atlas Desktop]$ rpm -qV java-1.6.0-openjdk-1.6.0.0-15.b14.fc10.x86_64
[ian@atlas Desktop]$ 

Though I note this is after reinstalling and trying again, trying it earlier I had:
[ian@atlas Desktop]$ rpm -qV java-1.6.0-openjdk-1.6.0.0-15.b14.fc10.x86_64
prelink: /tmp/#prelink#.RwlIoS: Recorded 6 dependencies, now seeing -1

S.?.....    /usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/bin/java
prelink: /tmp/#prelink#.XbrtFX: Recorded 6 dependencies, now seeing -1
etc...

java-1.6.0-openjdk-plugin was okay.  This is possibly connected with building the Java package locally to see if it would fix the problem.  The reinstall was via yum from the Fedora repos.  The problem persisted after reinstalling the openjdk package and restarting Firefox.

about-plugins IcedTea section attached.
Comment 3 Ian Malone 2009-04-24 03:23:45 EDT
It seems the FoxyTunes http://www.foxytunes.com/ plugin is involved somehow: disabling it seems to have stopped the crashing (tried disabling a few other ones without much effect, except that disabling AdBlock /sometimes/ avoided it).  Installed version is 3.5.4.1.  I suppose the next question is what is different about the way it's interacting with IcedTea and whether the crash is occurring in FT or IcedTea.  Will point the FoxyTunes people at this report.
Comment 4 Lillian Angel 2009-04-27 11:27:51 EDT
I installed FoxyTunes and tested out the Facebook app, everything seems to work fine. I am not sure what is happening on your system, but it is possible it is another applet interfering. can you retest and close this bug if it is invalid?

thanks!
Comment 5 Ian Malone 2009-04-27 19:12:39 EDT
I've tried disabling (not uninstalling, wont have time for that till the weekend) all plugins and extensions except for Icedtea and Foxytunes (which I have also re-installed and is rather oddly now at 3.0.4) with the same results.  This is now Firefox 3.0.9.  When I get a chance will see if I can do it from a clean profile.  Any suggestions for tracing the crash welcome.
Comment 6 Lillian Angel 2009-04-28 11:28:20 EDT
run it with ICEDTEAPLUGIN_DEBUG=true and then post
the /tmp/java.std* files in addition to the resulting console log. The
java.stderr will usually have the root cause.
Comment 7 Ian Malone 2009-04-28 19:14:52 EDT
Created attachment 341667 [details]
java.stdout for ICEDTEAPLUGIN_DEBUG=true
Comment 8 Ian Malone 2009-04-28 19:15:23 EDT
Created attachment 341668 [details]
java.stderr for ICEDTEAPLUGIN_DEBUG=true
Comment 9 Ian Malone 2009-04-28 19:21:04 EDT
Created attachment 341669 [details]
console output with  ICEDTEAPLUGIN_DEBUG=true

Cut and pasted in sections rather than piped
Comment 10 Lillian Angel 2009-05-11 13:15:12 EDT
Still can't reproduce this.
Comment 11 Ian Malone 2009-05-11 18:27:59 EDT
I've just tried creating a new user in Fedora and running Firefox under that with and without FoxyTunes (and now other extensions) and still get the crash with FoxyTunes installed.  Now on FF 3.0.10.  If you can think of anything else that be useful let me know.  I haven't actually used FoxyTunes for ages and don't mind going without it, but would be happy to help get to the bottom of why this might be happening.
Comment 12 Ian Malone 2009-06-02 19:44:32 EDT
Created attachment 346335 [details]
about:plugins

Newly updated openjdk still encounters this crash.  About plugins attached.  I notice that one of the fixes in the new openjdk is for a problem with invalid certificates; the certificate that appears for me when using the Facebook applet (with foxytunes disabled) shows "unable to verify", could this be related?
Comment 13 Steve 2009-10-03 09:30:45 EDT
I've also encountered this problem in Fedora 11 (32 bit), where the openjdk icedtea plugin crashes firefox.  When going to the Sun Java verification page

http://www.java.com/en/download/installed.jsp

Clicking on the Verify Java Version, firefox appears to try to start the openjdk plugin and then it crashes.  In the console, these are the messages:


loaded md5.js
/usr/lib/firefox-3.5.3/run-mozilla.sh: line 131:  5183 Segmentation fault      "$prog" ${1+"$@"}

Note that the Sun JRE plugin works fine with no crashes.
Comment 14 Steve 2009-10-03 09:33:34 EDT
Forgot to include some info about the java version installed:

java-1.6.0-openjdk-plugin-1.6.0.0-29.b16.fc11.i586
Comment 15 Bug Zapper 2009-11-18 06:49:16 EST
This message is a reminder that Fedora 10 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 10.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '10'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 10's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 10 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 16 Bug Zapper 2009-12-18 04:18:24 EST
Fedora 10 changed to end-of-life (EOL) status on 2009-12-17. Fedora 10 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.