Bug 496813 - [KMS] LVDS has only one available mode
[KMS] LVDS has only one available mode
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-21 05:47 EDT by Robert de Rooy
Modified: 2009-11-16 10:11 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-16 10:11:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert de Rooy 2009-04-21 05:47:16 EDT
Description of problem:
Not sure which component to raise this against. Since this is KMS related and effects both the Intel and Radeon support, I selected the Kernel.

When booting Fedora 11 Beta with latest updates on either a ThinkPad T41 with Radeon (rv250) or on a ThinkPad T60 with Intel (945GM) graphics, the ThinkPad display (LVDS) has only one mode available which is the native resolution if the display, which for both these ThinkPads happens to be 1400x1050.

Due to this no other modes can be selected, which might be a problem if your try to do one of the following;
- Mirror mode with an external display that does not support the same resolution
- Run something like a game full-screen at a lower resolution

A possible work-around might be to use xrandr to manually define additional modes, or disable KMS, in which case additional modes are available.

Not sure if this is a limitation of KMS with LVDS displays that is to be expected, but if such then it should at least be documented with possible workarounds in the release notes.

Version-Release number of selected component (if applicable):
kernel-2.6.29.1-100.fc11.x86_64
xorg-x11-drv-ati-6.12.2-4.fc11.x86_64
xorg-x11-drv-intel-2.7.0-1.fc11.x86_64

How reproducible:
every time

Steps to Reproduce:
1. Boot machine with LVDS display
2. Try to change default resolution
3.
  
Actual results:
Cannot select other resolutions on LVDS when booting with KMS

Expected results:
Being able to select other resolutions

Additional info:
===ThinkPad T41 with Radeon RV250===
01:00.0 VGA compatible controller: ATI Technologies Inc Radeon RV250 [Mobility FireGL 9000] (rev 02)

$ xrandr
Screen 0: minimum 320 x 200, current 1400 x 1050, maximum 4096 x 4096
VGA-0 disconnected (normal left inverted right x axis y axis)
DVI-0 disconnected (normal left inverted right x axis y axis)
LVDS connected 1400x1050+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
   1400x1050      50.0*+

===ThinkPad T60 with Intel 945GM===
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03)

$ xrandr
Screen 0: minimum 320 x 200, current 3000 x 1200, maximum 4096 x 4096
VGA1 disconnected (normal left inverted right x axis y axis)
LVDS1 connected 1400x1050+0+0 (normal left inverted right x axis y axis) 286mm x 214mm
   1400x1050      60.0*+   50.0  
DVI1 connected 1600x1200+1400+0 (normal left inverted right x axis y axis) 432mm x 324mm
   1600x1200      60.0*+
   1280x1024      75.0  
   1152x864       75.0  
   1024x768       75.1     70.1     60.0  
   832x624        74.6  
   800x600        72.2     75.0     60.3     56.2  
   640x480        72.8     75.0     66.7     60.0  
   720x400        70.1
Comment 1 Robert de Rooy 2009-05-10 02:52:39 EDT
With the new xorg-x11-drv-ati-6.12.2-13.fc11.i586 driver this issue seems like it has been resolved on the ATI side. with this driver installed I get the following now (remote ssh, not actually tested)

# xrandr
Screen 0: minimum 320 x 200, current 1400 x 1050, maximum 4096 x 4096
VGA-0 disconnected (normal left inverted right x axis y axis)
DVI-0 disconnected (normal left inverted right x axis y axis)
LVDS connected 1400x1050+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
   1400x1050      50.0*+
   1280x1024      60.0  
   1280x960       60.0  
   1024x768       60.0  
   800x600        60.3     56.2  
   640x480        59.9

On the other hand the INTEL driver still has the same issue.
Comment 2 Robert de Rooy 2009-05-11 03:12:20 EDT
Just a confirmation. on the ATI side all the resolutions listed seem to work properly.

Mirror mode still does not work, but that is another issue with the external VGA/DVI ports not activating (GDP gives an error that the configuration could not be applied (no reply) when you try to set mirror mode).

Again, that is a separate issue. For this bug report the one mode issue still exists with INTEL KMS.
Comment 3 Bug Zapper 2009-06-09 10:17:13 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Pedro Matiello 2009-06-14 22:09:57 EDT
I have the same issue. Only 1280x800 is available.

My Smolt Profile: http://www.smolts.org/client/show/pub_e5297f20-4db9-4a1a-a0bf-81876d0274fc
Comment 5 Robert de Rooy 2009-08-06 03:25:51 EDT
This issue is resolved in Rawhide with the xorg-x11-drv-intel-2.8 driver.

For the 2.7 driver used in F11 with KMS enabled, you can work around it by creating and running a script such as this, to add them manually.

# cat addmodes.sh 
#!/bin/bash
#
# modelines created with "gtf 640 480 60"
#
xrandr --newmode "1280x1024_60.00"  108.88  1280 1360 1496 1712  1024 1025 1028 1060  -HSync +Vsync
xrandr --newmode "1024x768_60.00"  64.11  1024 1080 1184 1344  768 769 772 795  -HSync +Vsync
xrandr --newmode "800x600_60.00"  38.22  800 832 912 1024  600 601 604 622  -HSync +Vsync
xrandr --newmode "640x480_60.00"  23.86  640 656 720 800  480 481 484 497  -HSync +Vsync
xrandr --addmode LVDS1 "1280x1024_60.00"
xrandr --addmode LVDS1 "1024x768_60.00"
xrandr --addmode LVDS1 "800x600_60.00"
xrandr --addmode LVDS1 "640x480_60.00"
Comment 6 James 2009-08-06 04:11:15 EDT
When will the 2.8 driver be backported to F11?
Comment 7 Adam Williamson 2009-08-06 16:10:23 EDT
As this is filed on F11, it can't be CLOSED RAWHIDE - we either fix it in F11 or say it won't be fixed and change the field to rawhide...

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 8 Matěj Cepl 2009-11-05 13:27:23 EST
Since this bugzilla report was filed, there have been several major updates in various components of the Xorg system, which may have resolved this issue. Users who have experienced this problem are encouraged to upgrade their system to the latest version of their packages. For packages from updates-testing repository you can use command

yum upgrade --enablerepo='*-updates-testing'

Alternatively, you can also try to test whether this bug is reproducible with the upcoming Fedora 12 distribution by downloading LiveMedia of F12 Beta available at http://alt.fedoraproject.org/pub/alt/nightly-composes/ . By using that you get all the latest packages without need to install anything on your computer. For more information on using LiveMedia take a look at https://fedoraproject.org/wiki/FedoraLiveCD .

Please, if you experience this problem on the up-to-date system, let us now in the comment for this bug, or whether the upgraded system works for you.

If you won't be able to reply in one month, I will have to close this bug as INSUFFICIENT_DATA. Thank you.

[This is a bulk message for all open Fedora Rawhide Xorg-related bugs. I'm adding myself to the CC list for each bug, so I'll see any comments you make after this and do my best to make sure every issue gets proper attention.]
Comment 9 Pedro Matiello 2009-11-11 18:01:27 EST
It's still not working in F11. I don't know about F12, though.
Comment 10 Robert de Rooy 2009-11-12 03:44:14 EST
As mentioned before, this bug is fixed in F12 with the newer intel Xorg driver. As long as the newer driver version is not made available for F11 (or the fix backported to the old driver), F11 will require the workaround I mentioned in comment #5 of manually adding modes.

Personally I have upgraded already to F12, and as such, this issue for me is solved.
Comment 11 Matěj Cepl 2009-11-16 10:11:34 EST
Thank you for letting us know.

Note You need to log in before you can comment on or make changes to this bug.