This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 496851 - erlang-debuginfo does not contain sources
erlang-debuginfo does not contain sources
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: erlang (Show other bugs)
11
All Linux
high Severity medium
: ---
: ---
Assigned To: Gérard Milmeister
Fedora Extras Quality Assurance
https://www.redhat.com/archives/fedor...
:
Depends On:
Blocks: DebugInfo
  Show dependency treegraph
 
Reported: 2009-04-21 09:12 EDT by Debarshi Ray
Modified: 2009-08-08 08:13 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-08 08:13:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Updated Spec. (7.01 KB, text/plain)
2009-04-21 09:27 EDT, Debarshi Ray
no flags Details
Updated otp-rpath.patch. (1.57 KB, patch)
2009-04-21 09:28 EDT, Debarshi Ray
no flags Details | Diff
Updated otp-rpath.patch. (1.82 KB, patch)
2009-04-21 10:42 EDT, Debarshi Ray
no flags Details | Diff

  None (edit)
Description Debarshi Ray 2009-04-21 09:12:33 EDT
Description of problem:
The debuginfo sub-package is supposed to contain the source files, which is not
the case for Erlang.

Version-Release number of selected component (if applicable):
All versions currently available for Rawhide, Fedora 11, Fedora 10 and Fedora
9.
Comment 1 Debarshi Ray 2009-04-21 09:27:35 EDT
Created attachment 340518 [details]
Updated Spec.
Comment 2 Debarshi Ray 2009-04-21 09:28:13 EDT
Created attachment 340519 [details]
Updated otp-rpath.patch.
Comment 3 Debarshi Ray 2009-04-21 09:29:44 EDT
Please request a freeze override for Fedora 11 according to
https://fedoraproject.org/wiki/ReleaseEngineering/FinalFreezePolicy
Comment 4 Debarshi Ray 2009-04-21 10:42:26 EDT
Created attachment 340538 [details]
Updated otp-rpath.patch.
Comment 5 Gérard Milmeister 2009-04-21 14:24:49 EDT
I have koji-built for F11+ using your patch.
I don't think it is necessary to request a freeze override.
Comment 6 Debarshi Ray 2009-04-21 14:36:41 EDT
(In reply to comment #5)
> I have koji-built for F11+ using your patch.
> I don't think it is necessary to request a freeze override.

In that case we would be shipping a broken debuginfo in Fedora 11 GA, and if pushed as an update it would be unfair to those who use automatic updates, because their normal packages would not be affected.

For what it is worth, Release Engineering has already approved freeze overrides for some broken debuginfo candidates, whose maintainers had raised tickets. eg., osmo, curl.
Comment 7 Gérard Milmeister 2009-04-21 17:41:25 EDT
I created a ticket: 
https://fedorahosted.org/rel-eng/ticket/1582
Comment 8 Bug Zapper 2009-06-09 10:18:06 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Note You need to log in before you can comment on or make changes to this bug.