Bug 496853 - [MinimalPlatform] Bad dependencies in xscreensaver
Summary: [MinimalPlatform] Bad dependencies in xscreensaver
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: xscreensaver   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Mamoru TASAKA
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On: F11MinimalPlatform
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-04-21 13:28 UTC by Vitaly Mayatskikh
Modified: 2009-04-21 21:50 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-21 14:42:36 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Vitaly Mayatskikh 2009-04-21 13:28:51 UTC
XScreensaver requires too many dependencies:

# rpm -qR xscreensaver
xscreensaver-base = 1:5.08-9.fc11
xscreensaver-extras = 1:5.08-9.fc11
xscreensaver-gl-extras = 1:5.08-9.fc11
rpmlib(FileDigests) <= 4.6.0-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(CompressedFileNames) <= 3.0.4-1

xscreensaver-gl-extras also requires xscreensaver-gl-base

IMO, xscreensaver should depend only on xscreensaver-base.

Comment 1 Mamoru TASAKA 2009-04-21 14:42:36 UTC
xscreensaver binary rpm is actually a virtual package to install
3 packages mentioned here (i.e. xscreensaver-{base,extras,gl-extras})
by just "yum install xscreensaver".

If you want to use minimal function of xscreensaver, just
install "xscreensaver-base". Note that xscreensaver binary rpm
is introduced by me and I think only Fedora creates xscreensaver
(virtual) package.


Note You need to log in before you can comment on or make changes to this bug.