Bug 496885 - Regression: Munin graphs with variable instead with monospaced font
Regression: Munin graphs with variable instead with monospaced font
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: munin (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Kevin Fenzi
Fedora Extras Quality Assurance
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-21 10:45 EDT by Uwe Menges
Modified: 2011-04-08 05:46 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-04 10:58:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Munin graph on FC7 - how it should be (20.57 KB, image/png)
2009-04-21 10:45 EDT, Uwe Menges
no flags Details
Munin graph on FC10 - how it is (18.63 KB, image/png)
2009-04-21 10:46 EDT, Uwe Menges
no flags Details

  None (edit)
Description Uwe Menges 2009-04-21 10:45:29 EDT
Created attachment 340539 [details]
Munin graph on FC7 - how it should be

Description of problem:
Munin now creates graphs with variable font instead of monospace font, and this causes the values to be not aligned.

Version-Release number of selected component (if applicable):
1.2.6-3.fc10

How reproducible:
Always.

Steps to Reproduce:
1. Install munin
2. Let it graph something
3.
  
Actual results:
Graphs are created with variable font.

Expected results:
Graphs are created with fixed/monospace font.

Additional info:
Comment 1 Uwe Menges 2009-04-21 10:46:34 EDT
Created attachment 340540 [details]
Munin graph on FC10 - how it is
Comment 2 Kevin Fenzi 2009-04-25 15:31:07 EDT
Hum. It only has a monospaced font. I suspect it's something to do with how it's rending the images or aligning them. 

F7 used a much older rrdtool, so perhaps thats where the problem is. 

I will try and see if I can track it down.
Comment 3 Kevin Fenzi 2009-07-04 02:41:09 EDT
ok, in F7 munin used an internal VeraMono.ttf font for it's graphs. 
In recent versions it uses DejaVuSansMono.ttf. 

I wonder if somehow the spacing is too tied to that font. ;( 
I suppose we could try another monospaced font...
Comment 4 Bug Zapper 2009-11-18 06:49:21 EST
This message is a reminder that Fedora 10 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 10.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '10'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 10's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 10 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Kevin Fenzi 2009-11-18 11:40:24 EST
Are you still seeing this? I'm not sure it's the case in f11 here... 

Also, I am working on the new 1.4.0 release, and it seems to have a much nicer graphing layout.
Comment 6 Uwe Menges 2009-11-23 10:56:13 EST
I just tested with F12 (munin-1.2.6-10.fc12.noarch), same result as with F10 or F11 - still unaligned values.

I could probably get rid of the issue by telling munin-graph to use another, fixed font - just I don't know how to accomplish this. I even tried to copy the old font there, but that didn't change anything.

If you can give me a hint where I can choose the font used in the munin graphs, I'd be glad to experiment with it. I just don't know how I'm officially supposed to do this, and my own testings didn't reveal anything.
Comment 7 Kevin Fenzi 2009-11-23 12:40:23 EST
It uses: 

/usr/share/munin/VeraMono.ttf

Which used to be it's own copy of that font, and now points to
/usr/share/fonts/dejavu/DejaVuSansMono.ttf
Which is supposed to be a replacement. ;( 

Feel free to play around with changing that font and let me know which one works for you, and/or whats different about the DejaVu one.
Comment 8 Kevin Fenzi 2010-01-17 14:14:55 EST
Uwe: Can you test with the munin version in updates-testing? 
See if it looks any better for you... there are a lot of changes in 1.4.x verses 1.2.x.
Comment 9 Uwe Menges 2010-02-04 06:09:29 EST
I just installed munin-1.4.3-2.fc12.noarch.rpm from updates-testing, and now the values are aligned again.
Comment 10 Kevin Fenzi 2010-02-04 10:58:43 EST
Hurray! ;) 

I guess we can close this one for now then?
If you spot further problems with it, please file a new bug or re-open this one.
Comment 11 Squirrelly 2011-04-08 05:46:29 EDT
Just want to thank Kevin Fenzi and make a note for others that might run into this.  When my cPanel updated Munin, it started showing just blocks for all text.  From Comment 7 above, I found I had no /usr/share/fonts/dejavu/ directory under my RH9.  So I created that folder and copied the /usr/share/munin/DejaVuSans*.ttf files to it.  And now as Munin gets around to updating the graphs they are showing correct text again.  Well there are still some alignment issues, but that's better than blocks.  Thank you! :-)

Note You need to log in before you can comment on or make changes to this bug.