Bug 496950 - yum crashes with AttributeError: 'NoneType' object has no attribute 'getRequires'
yum crashes with AttributeError: 'NoneType' object has no attribute 'getRequi...
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-21 14:52 EDT by Andrew McNabb
Modified: 2014-01-21 18:09 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-13 14:32:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
traceback (1.83 KB, text/plain)
2009-04-21 14:52 EDT, Andrew McNabb
no flags Details

  None (edit)
Description Andrew McNabb 2009-04-21 14:52:56 EDT
Created attachment 340607 [details]
traceback

I have a little "yum shell" script that adds and removes a variety of packages.  I installed Fedora 11 and ran "yum -y shell myscript.yum" and got a crash with a traceback (which I'll attach).

I believe that the error may have been indirectly caused by a misconfigured repo file in yum.repos.d.  When I ran yum directly, I got a "Cannot retrieve repository metadata (repomd.xml) for repository" error.  After disabling the offending repository, my "yum shell" script seemed to work.  This may help in reproducing the problem.

If necessary, I can provide the script I was using.
Comment 1 James Antill 2009-04-21 16:20:46 EDT
Where there any other messages before the traceback?
Can you reproduce it now, by breaking the repo again?
Comment 2 Andrew McNabb 2009-04-21 16:38:59 EDT
The following is the full output from yum on stdout:

"""
Loaded plugins: refresh-packagekit
Setting up Yum Shell
Setting up Install Process
Setting up Remove Process
--> Running transaction check
---> Package sendmail.i586 0:8.14.3-5.fc11 set to be erased
"""
Comment 3 Christopher Beland 2009-04-22 13:06:08 EDT
What was the version number of yum when it crashed?
Comment 4 Andrew McNabb 2009-04-22 13:47:47 EDT
It's whatever the newest yum was in Rawhide two days ago.  I'm pretty sure it was yum-3.2.22-4.fc11.noarch.
Comment 5 Bug Zapper 2009-06-09 10:20:53 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 seth vidal 2009-07-10 12:08:15 EDT
Is this still happening on 3.2.23  from f11?
Comment 7 Andrew McNabb 2009-07-13 13:58:03 EDT
I tried to reproduce it by breaking one of the repo files.  It looks like it might have been fixed.  Unfortunately, it's been so long since my original bug report that I can't reproduce the entire environment.  If there was some other cause than my original theory (a broken repo file), then I can't track it down.  This machine has been reinstalled two or three times in the last three months.
Comment 8 seth vidal 2009-07-13 14:32:04 EDT
thanks, closing.

Note You need to log in before you can comment on or make changes to this bug.