Bug 496962 - Intel KMS regression for i915 chipset
Intel KMS regression for i915 chipset
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Kristian Høgsberg
Fedora Extras Quality Assurance
:
Depends On:
Blocks: IntelKMS
  Show dependency treegraph
 
Reported: 2009-04-21 16:13 EDT by Michael Wiktowy
Modified: 2009-05-04 11:59 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-04 11:59:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lspci (2.57 KB, text/plain)
2009-04-21 16:13 EDT, Michael Wiktowy
no flags Details
lsmod (1.80 KB, text/plain)
2009-04-21 16:14 EDT, Michael Wiktowy
no flags Details

  None (edit)
Description Michael Wiktowy 2009-04-21 16:13:05 EDT
Created attachment 340625 [details]
lspci

Description of problem:
xorg-x11-drv-intel-2.6.99.902-2.fc11 (as seen on Fedora 11 Snapshot 1 LiveCD) works flawlessly for the i915 onboard video on the Dell Optiplex 760. Upgrading to xorg-x11-drv-intel-2.7.0-1.fc11 causes the screen to be corrupted when the system loads the GDM and beyond that point. Each subsequent horizontal line has been shifted some offset from the one before instead of being aligned. You can see remnants of the top and bottom panel but everything is blended up. 

Version-Release number of selected component (if applicable):
xorg-x11-drv-intel-2.6.99.902-2.fc11 (as seen on Fedora 11 Snapshot 1 LiveCD) works
xorg-x11-drv-intel-2.7.0-1.fc11 broken

How reproducible:
Always on this machine

Steps to Reproduce:
1. Boot from Fedora 11 Snap1 x86_64 LiveUSB on an Optiplex 760 with persistent storage
2. Upgrade to xorg-x11-drv-intel-2.7.0-1.fc11
3. Reboot
  
Additional info:
See attached lspci -nn and lsmod
Comment 1 Michael Wiktowy 2009-04-21 16:14:02 EDT
Created attachment 340627 [details]
lsmod
Comment 2 Michael Wiktowy 2009-04-21 16:42:25 EDT
As additional note, I discovered this when I just updated *everything* (including the kernel) from Snapshot 1 to latest Rawhide. If I did that, I didn't get the video corruption, I just got black screen and frozen system just as the boot sequence was about to switch to GDM.

I then switched back to a Snapshot 1 starting point and just updated the Intel driver which didn't bring in any other dependencies. That shows screen corruption.

I can't seem to update just the kernel (with firmware dependency) from kernel.x86_64 2.6.29.1-54 to 2.6.29.1-100 since there seems to be no way to boot to the new kernel though the LiveUSB bootloader.

I can boot normally (without pretty boot) by using the "nomodeset" kernel parameter. I also have to use the acpi=ht parameter to boot but that is another separate issue with the power management, I would guess.
Comment 3 Matěj Cepl 2009-04-23 09:58:48 EDT
Could we get /var/log/Xorg.0.log, /var/log/dmesg as well, please?
Comment 4 Michael Wiktowy 2009-05-04 11:59:46 EDT
Sorry for the delay as I was out of town.

I have downloaded and made a LiveUSB out of the F11 Preview Release and the Intel driver seems to be back in working order for this chipset. Actually, the Intel driver is the same version as before but I guess that changes in the kernel (now kernel 2.6.29.1-102.fc11) may have sorted out the issue.

I still need to use acpi=ht to boot but will start another bug for that since that seems to be a too aggressive power saving issue.

Note You need to log in before you can comment on or make changes to this bug.