Bug 496965 - [5.3] Unnecessary error messages displayed when mounting fs fails
[5.3] Unnecessary error messages displayed when mounting fs fails
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kexec-tools (Show other bugs)
5.3
All Linux
low Severity medium
: rc
: 5.4
Assigned To: Neil Horman
Red Hat Kernel QE team
: OtherQA
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-21 16:42 EDT by Keiichiro Tokunaga
Modified: 2013-07-04 19:49 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 600597 (view as bug list)
Environment:
Last Closed: 2009-09-02 05:14:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
A proposal patch (801 bytes, patch)
2009-04-21 16:42 EDT, Keiichiro Tokunaga
no flags Details | Diff

  None (edit)
Description Keiichiro Tokunaga 2009-04-21 16:42:31 EDT
Created attachment 340629 [details]
A proposal patch

Description of problem:
The following two lines are displayed when mounting fs fails at the
2nd kernel (kdump kernel) boot time.

  umount: Couldn't umount /mnt: Invalid argument
  [: 0: unknown operand

Version-Release number of selected component (if applicable):
kexec-tools-1.102pre-56.el5

How reproducible:
Always (when mounting fs fails).

Steps to Reproduce:
1. Configure kdump.conf to use a filesystem.
2. Trigger a panic or something so the 2nd kernel starts booting.
  
Actual results:
The two lines are displayed.

Expected results:
The two lines are not displayed.

Additional info:
A proposal patch attached.  It just follows the manner done in the
nfs case.  The patch is against the latest kexec-tools (1.102pre-65.el5)
as of today.
Comment 1 Neil Horman 2009-04-22 06:13:40 EDT
yeah, seems reasonable.  Thanks!
Comment 2 Neil Horman 2009-04-22 10:35:52 EDT
fixed in -67.el5.  Thanks!
Comment 4 Chris Ward 2009-07-03 14:42:38 EDT
~~ Attention - RHEL 5.4 Beta Released! ~~

RHEL 5.4 Beta has been released! There should be a fix present in the Beta release that addresses this particular request. Please test and report back results here, at your earliest convenience. RHEL 5.4 General Availability release is just around the corner!

If you encounter any issues while testing Beta, please describe the issues you have encountered and set the bug into NEED_INFO. If you encounter new issues, please clone this bug to open a new issue and request it be reviewed for inclusion in RHEL 5.4 or a later update, if it is not of urgent severity.

Please do not flip the bug status to VERIFIED. Only post your verification results, and if available, update Verified field with the appropriate value.

Questions can be posted to this bug or your customer or partner representative.
Comment 5 Chris Ward 2009-07-10 15:12:51 EDT
~~ Attention Partners - RHEL 5.4 Snapshot 1 Released! ~~

RHEL 5.4 Snapshot 1 has been released on partners.redhat.com. If you have already reported your test results, you can safely ignore this request. Otherwise, please notice that there should be a fix available now that addresses this particular request. Please test and report back your results here, at your earliest convenience. The RHEL 5.4 exception freeze is quickly approaching.

If you encounter any issues while testing Beta, please describe the issues you have encountered and set the bug into NEED_INFO. If you encounter new issues, please clone this bug to open a new issue and request it be reviewed for inclusion in RHEL 5.4 or a later update, if it is not of urgent severity.

Do not flip the bug status to VERIFIED. Instead, please set your Partner ID in the Verified field above if you have successfully verified the resolution of this issue. 

Further questions can be directed to your Red Hat Partner Manager or other appropriate customer representative.
Comment 6 Caspar Zhang 2009-07-20 04:52:07 EDT
(In reply to comment #0)
> Created an attachment (id=340629) [details]
> A proposal patch
> 
> Description of problem:
> The following two lines are displayed when mounting fs fails at the
> 2nd kernel (kdump kernel) boot time.
> 
>   umount: Couldn't umount /mnt: Invalid argument
>   [: 0: unknown operand
> 
> Version-Release number of selected component (if applicable):
> kexec-tools-1.102pre-56.el5
> 
> How reproducible:
> Always (when mounting fs fails).
> 
> Steps to Reproduce:
> 1. Configure kdump.conf to use a filesystem.
> 2. Trigger a panic or something so the 2nd kernel starts booting.
> 
> Actual results:
> The two lines are displayed.
> 
> Expected results:
> The two lines are not displayed.
> 
> Additional info:
> A proposal patch attached.  It just follows the manner done in the
> nfs case.  The patch is against the latest kexec-tools (1.102pre-65.el5)
> as of today.  

How can you produce "Invalid Argument" in umount, can you give a command? I don't know how to get an "umount: Couldn't umount /mnt: Invalid argument" error message, thus I can't reproduce this bug.
Comment 9 Keiichiro Tokunaga 2009-08-06 19:22:57 EDT
If mounting the filesystem fails, the "Invalid Argument" should be shown.  And, to make the mount failure happen, I think you can modify mkdumprd a bit.  For example, inserting "dd if=/dev/zero of=<filesystem> count=1000 bs=1024" right before the "mount" command runs, or changing the line of "mount" command to 
"ls there-is-no-file" or something should work.
Comment 10 errata-xmlrpc 2009-09-02 05:14:05 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1258.html

Note You need to log in before you can comment on or make changes to this bug.