Bug 496974 - java-1.6.0-sun-jdbc-1.6.0.13-1jpp.1.el5.x86_64 from rhel-x86_64-client-supplementary-5 has depsolving problems
java-1.6.0-sun-jdbc-1.6.0.13-1jpp.1.el5.x86_64 from rhel-x86_64-client-supple...
Status: CLOSED CANTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: java-1.6.0-sun (Show other bugs)
5.3
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Deepak Bhole
BaseOS QE
:
: 557508 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-21 17:20 EDT by santiago angel
Modified: 2010-06-30 16:11 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-30 16:11:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description santiago angel 2009-04-21 17:20:16 EDT
Description of problem:

java-1.6.0-sun-jdbc-1.6.0.13-1jpp.1.el5.x86_64 from rhel-x86_64-client-supplementary-5 has depsolving problems


Version-Release number of selected component (if applicable):
java-1.6.0-sun-jdbc-1.6.0.13-1jpp.1.el5.x86_64

How reproducible:
try to install java-1.6.0-sun-jdbc-1.6.0.13-1jpp.1.el5.x86_64

Steps to Reproduce:
1.yum install java-1.6.0-sun-jdbc-1.6.0.13-1jpp.1.el5.x86_64
2.
3.
  
Actual results:
depsolving problems 
Missing Dependency: /usr/lib64/libodbcinst.so is needed by package
but unixODBC only provides /usr/lib64/libodbcinst.so.1


Expected results:
install without problems

Additional info:
Comment 1 Radek Bíba 2009-04-22 01:53:16 EDT
# rpm -qf /usr/lib64/libodbcinst.so
unixODBC-devel-2.2.11-7.1.x86_64

This package is available in channel rhel-x86_64-client-workstation-5. Maybe you're not subscribed to it?
Comment 2 santiago angel 2009-04-22 04:08:15 EDT
Yes, my system is subscribed to red hat enterprise linux desktop

and has no rights to rhel-x86_64-client-workstation-5.

But why is java available in the supplementary channel for red hat enterprise linux desktop if needs software from an inaccessible channel (for my entitlement)?
Comment 3 Radek Bíba 2009-04-22 04:38:14 EDT
Well, java-1.6.0-sun can't really do anything about that. In fact it's a
packaging issue on the unixODBC side (reported internally in a private bug; I'll update it with the problem you're describing).

For now, I guess you really need to gain access to the Workstation channel in order to be able to get the jdbc subpackage.
Comment 4 Radek Bíba 2010-02-15 06:47:35 EST
*** Bug 557508 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.