Bug 496987 - automount cannot find NIS/YP domain name
automount cannot find NIS/YP domain name
Status: CLOSED DUPLICATE of bug 494827
Product: Fedora
Classification: Fedora
Component: ypbind (Show other bugs)
10
i386 Linux
low Severity low
: ---
: ---
Assigned To: Vitezslav Crhonek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-21 18:27 EDT by Brian Dudek
Modified: 2009-04-22 01:39 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-22 01:39:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian Dudek 2009-04-21 18:27:41 EDT
Description of problem:

I do not have an issue with something broken exactly but I see these three messages in this order in /var/log/message

Apr 21 15:48:55 localhost automount[1851]: lookup_init:136: lookup(yp): map auto.master: Local domain name not set
Apr 21 15:48:55 localhost automount[1851]: lookup_init:136: lookup(yp): map auto_home: Local domain name not set
Apr 21 15:48:55 localhost ypbind: NIS domain: entropy, NIS server: shadow


Version-Release number of selected component (if applicable):

autofs-5.0.3-41.i386
ypbind-1.20.4-10.fc10.i386


How reproducible:

during system reboot


Steps to Reproduce:
1.enable both autofs and ypbing
2.configure both
3.reboot system
  
Actual results:


Expected results:


Additional info:
I think the issue is that S28autofs starts BEFORE (alphabetically) S28ypbind so autofs doesn't yet have the YP domain

Solution:

Rename S28ypbind to S27ypbind so that nis starts first.  After this no more syslog error reported.
Comment 1 Vitezslav Crhonek 2009-04-22 01:39:54 EDT

*** This bug has been marked as a duplicate of bug 494827 ***

Note You need to log in before you can comment on or make changes to this bug.