Bug 497069 - XVideo fails if multihead monitor size exceeds 2k in any direction
Summary: XVideo fails if multihead monitor size exceeds 2k in any direction
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel
Version: 12
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Adam Jackson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Triaged
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-04-22 08:57 UTC by Ralf Ertzinger
Modified: 2018-04-11 11:04 UTC (History)
4 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2010-12-05 06:56:01 UTC


Attachments (Terms of Use)
Xorg.0.log (237.04 KB, text/plain)
2009-04-22 09:08 UTC, Ralf Ertzinger
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 583471 None None None Never

Internal Trackers: 583471

Description Ralf Ertzinger 2009-04-22 08:57:20 UTC
Description of problem:
Hardware: Intel 945GM Chipset in a Thinkpad X60s

With the latest release the driver allows an xrandr size of 4096x4096. This works
as far as I can tell (I can run 1024x768 and 1920x1200 side by side).

If the total size exceeds 2048 pixels, however, XVideo stops working. mplayer opens the video window and starts playback, but the video remains black. Reducing the size below 2048 makes XVideo work again.

a) Single 1024x768 screen: xvideo works
b) 1920x1200 above 1024x768: xvideo works (video can be moved across both monitors)
c) 1920x1200 left (or right) of 1024x768: xvideo does not work (black window)
d) back to b): xvideo works again


Version-Release number of selected component (if applicable):
xorg-x11-drv-intel-2.7.0-1.fc11.i586

How reproducible:
Always

Steps to Reproduce:
1. see above
2.
3.
  
Actual results:


Expected results:


Additional info:
Besides this issue I am quite happy with the 2.7 series of drivers. KMS works without slowdowns, large xrandr size and no more video tearing.

Comment 1 Ralf Ertzinger 2009-04-22 09:08:29 UTC
Created attachment 340698 [details]
Xorg.0.log

Comment 2 Adam Jackson 2009-04-23 19:06:24 UTC
That's expected, unfortunately.  The XV adaptor uses the YUV texture support in the 3D engine.  The 915 and 945's 3D engine are crippled and can't address destination surfaces larger than 2k wide.

There's a sense in which we could try to make this work by double-buffering the blit: once from YUV to RGB offscreen with the 3D engine, and then from that temporary surface to the screen with the 2D engine.  It'd be kind of unpleasant to implement, but probably doable.

Comment 3 Ralf Ertzinger 2009-04-23 21:15:15 UTC
Does "destination surface" mean the size of the xv window (i.e. the size of my video output) or the virtual desktop size? The xv window itself was never larger than 2k pixels, just the virtual desktop.

Comment 4 Adam Jackson 2009-04-23 22:37:06 UTC
Virtual desktop size.  When no compositing manager is running, all windows share storage with the root window.

Comment 5 Bug Zapper 2009-06-09 14:23:10 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 7 Matěj Cepl 2009-11-05 18:27:27 UTC
Since this bugzilla report was filed, there have been several major updates in various components of the Xorg system, which may have resolved this issue. Users who have experienced this problem are encouraged to upgrade their system to the latest version of their packages. For packages from updates-testing repository you can use command

yum upgrade --enablerepo='*-updates-testing'

Alternatively, you can also try to test whether this bug is reproducible with the upcoming Fedora 12 distribution by downloading LiveMedia of F12 Beta available at http://alt.fedoraproject.org/pub/alt/nightly-composes/ . By using that you get all the latest packages without need to install anything on your computer. For more information on using LiveMedia take a look at https://fedoraproject.org/wiki/FedoraLiveCD .

Please, if you experience this problem on the up-to-date system, let us now in the comment for this bug, or whether the upgraded system works for you.

If you won't be able to reply in one month, I will have to close this bug as INSUFFICIENT_DATA. Thank you.

[This is a bulk message for all open Fedora Rawhide Xorg-related bugs. I'm adding myself to the CC list for each bug, so I'll see any comments you make after this and do my best to make sure every issue gets proper attention.]

Comment 8 Robert de Rooy 2010-02-19 10:19:13 UTC
Still the same issue (obviously) with current Fedora 12. In this case with a ThinkPad T60 with 945GM. Easily reproducible with a webcam and something like Cheese.

kernel-2.6.32.8-48.rc2.fc12.x86_64
xorg-x11-server-Xorg-1.7.5-1.fc12.x86_64
xorg-x11-drv-intel-2.9.1-1.fc12.x86_64

Comment 9 Robert de Rooy 2010-02-25 12:14:09 UTC
clear Needinfo flag

kernel-2.6.32.8-58.fc12.x86_64
xorg-x11-server-Xorg-1.7.5-3.fc12.x86_64
xorg-x11-drv-intel-2.9.1-1.fc12.x86_64

Comment 10 Robert de Rooy 2010-03-10 13:45:53 UTC
I just tried F13 Alpha, and there is no change

xorg-x11-drv-intel-2.10.0-4.fc13
kernel-2.6.33-8.fc13

Comment 11 Robert de Rooy 2010-04-16 06:55:34 UTC
Two possible workarounds if your experiencing this issue.

a) Change to "no xv" output. For Gstreamer apps here is the procedure
https://fedoraproject.org/wiki/QA:Testcase_intelvideo_xv
Just instead of changing the output to "X Window System (X11/Xshm/Xv)", change it to "X Window (No Xv)". This will result in higher CPU usage for playback though.

b) As hinted by Adam Jackson, turn on compositing in Metacity. Here is the procedure
https://fedoraproject.org/wiki/QA:Testcase_intelvideo_compositing_manager

Comment 12 Bug Zapper 2010-11-04 11:19:27 UTC
This message is a reminder that Fedora 12 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 12.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '12'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 12's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 12 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 13 Bug Zapper 2010-12-05 06:56:01 UTC
Fedora 12 changed to end-of-life (EOL) status on 2010-12-02. Fedora 12 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.