Bug 497147 - UnboundedLocalError: local variable 'request' referenced before assignment
UnboundedLocalError: local variable 'request' referenced before assignment
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-22 10:34 EDT by Eric Paris
Modified: 2009-04-23 16:35 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-23 16:35:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Paris 2009-04-22 10:34:17 EDT
anaconda 11.5.0.46

Last 4 lines of the traceback are:
File "/usr/lib/python2.6/site-packages/pykickstart/base.py", line 376, in dispatcher
 obj = self.commands[cmd].parse(args[1:])
File "/usr/lib/anaconda/kickstart.py", line 440, in parse
 luksformat = request.format

UnboundedLocalError: local variable 'request' referenced before assignment

kickstart file contains:

part /boot --fstype ext3 --onpart=sda1
part swap --onpart=sda5
part pv.1 --onpart=sda3 --noformat
part pv.2 --onpart=sda2 --noformat
part /export --fstype btrfs --noformat --onpart=sda6

volgroup VGF1164 --pesize=32768 pv.1 --useexisting
logvol /home --vgname=VGF1164 --fstype btrfs --name LVHOME --size=4096 --encrypted --passphrase=******** --useexisting
logvol / --vgname=VGF1164 --fstype btrfs --name LVROOT --size=1 --grow --useexisting

volgroup VGVIRT --pesize=32768 pv.2 --noformat
logvol /var/lib/libvirt/images --vgname=VGVIRT --fstype btrfs --name LVVIRT --size=1 --grow --noformat
Comment 1 Chris Lumens 2009-04-22 13:18:09 EDT
Can you please test with updates=http://clumens.fedorapeople.org/497147.img?  It looks like the combination of --encrypted --useexisting is what's causing problems here.  Thanks.
Comment 2 Eric Paris 2009-04-23 13:20:35 EDT
anaconda 11.5.0.47 + updates=http://clumens.fedorapeople.org/497147.img appears to be at least formatting devices so I guess this is good!
Comment 3 Chris Lumens 2009-04-23 16:35:21 EDT
This should be fixed in the next build of anaconda, then.  Thanks for testing the fix.

Note You need to log in before you can comment on or make changes to this bug.