Bug 497166 - numpy ImportError: No module named linalg
numpy ImportError: No module named linalg
Status: CLOSED DUPLICATE of bug 496277
Product: Fedora
Classification: Fedora
Component: numpy (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: Jon Ciesla
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-22 12:03 EDT by Andrew McNabb
Modified: 2009-04-23 08:31 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-23 08:31:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Andrew McNabb 2009-04-22 12:03:35 EDT
Doing an "import numpy" fails with a traceback:

Python 2.6 (r26:66714, Mar 17 2009, 11:44:14) 
[GCC 4.4.0 20090313 (Red Hat 4.4.0-0.26)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import numpy
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "/usr/lib64/python2.6/site-packages/numpy/__init__.py", line 130, in <module>
    import add_newdocs
  File "/usr/lib64/python2.6/site-packages/numpy/add_newdocs.py", line 9, in <module>
    from lib import add_newdoc
  File "/usr/lib64/python2.6/site-packages/numpy/lib/__init__.py", line 13, in <module>
    from polynomial import *
  File "/usr/lib64/python2.6/site-packages/numpy/lib/polynomial.py", line 18, in <module>
    from numpy.linalg import eigvals, lstsq
ImportError: No module named linalg
>>>
Comment 1 Andrew McNabb 2009-04-22 12:05:39 EDT
It looks like 1.3.0-3 should fix this, but it hasn't been pushed out to the mirrors.
Comment 2 Jon Ciesla 2009-04-23 08:31:51 EDT

*** This bug has been marked as a duplicate of bug 496277 ***

Note You need to log in before you can comment on or make changes to this bug.