Bug 497177 - pulseaudio --system mode fails
pulseaudio --system mode fails
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks: K12LTSP
  Show dependency treegraph
 
Reported: 2009-04-22 12:56 EDT by Warren Togami
Modified: 2009-04-22 16:51 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-22 16:51:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Warren Togami 2009-04-22 12:56:00 EDT
pulseaudio-0.9.15-10.fc11

Thin client running pulseaudio as system daemon, GNOME desktop running remotely over ssh tunnel.

                /usr/bin/pulseaudio --system \
                --exit-idle-time=-1 \
                --disable-shm \
                --no-cpu-limit \
                --resample-method=trivial \
                --high-priority \
                --log-target=syslog \
                -L module-detect \
                -L "module-esound-protocol-tcp auth-anonymous=1" \
                -L "module-native-protocol-tcp auth-anonymous=1" \
                -L module-volume-restore \
                -L module-rescue-streams \
                -L "module-native-protocol-unix auth-anonymous=1" \
                -n &

main.c: Running in system mode, but --disallow-exit not set!
main.c: Running in system mode, but --disallow-module-loading not set!
module.c: Failed to load  module "module-alsa-sink" (argument: "device_id=0"): initialization failed.
module.c: Failed to load  module "module-alsa-source" (argument: "device_id=0"): initialization failed.
module-detect.c: failed to detect any sound hardware.
module.c: Failed to load  module "module-detect" (argument: ""): initialization failed.
main.c: Module load failed.
main.c: Failed to initialize daemon.

These parameters worked with pulseaudio in F-9 and F-10.  What changed in pulseaudio F-11?

Do we need to change parameters to pulseaudio system daemon?
Will these new parameters work with pulseaudio F-9 and F-10?
Comment 1 Lennart Poettering 2009-04-22 15:52:46 EDT
Looks like a permission problem. Could you please get me the full debug output with -vvvvvvvvv?
Comment 2 Warren Togami 2009-04-22 16:51:41 EDT
Permission problem, fixed elsewhere.

Note You need to log in before you can comment on or make changes to this bug.