Bug 497185 - [LTC 6.0 FEAT] Timer migration from idle CPUs [201926]
[LTC 6.0 FEAT] Timer migration from idle CPUs [201926]
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.0
All All
low Severity high
: rc
: ---
Assigned To: Peter Martuccelli
Martin Jenner
: FutureFeature
Depends On:
Blocks: 356741
  Show dependency treegraph
 
Reported: 2009-04-22 13:40 EDT by IBM Bug Proxy
Modified: 2010-05-10 13:25 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-15 09:13:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
IBM Linux Technology Center 52945 None None None Never

  None (edit)
Description IBM Bug Proxy 2009-04-22 13:40:49 EDT
=Comment: #0=================================================
Emily J. Ratliff <ratliff@austin.ibm.com> - 
1. Feature Overview:
Feature Id:	[201926]
a. Name of Feature:	Timer migration from idle CPUs
b. Feature Description
In an SMP system, tasks are scheduled on different CPUs by the scheduler, interrupts are managed by
irqbalancer daemon, but timers are still stuck to the CPUs that they have been initialised.  Timers
 queued by tasks gets re-queued on the CPU where the task gets to run next, but timers from IRQ
context like the ones in device drivers are still stuck on the CPU they were initialised.

2. Feature Details:
Sponsor:	Linux Systems Tech
Architectures:
x86_64
ppc64
s390x

Arch Specificity: Purely Common Code
Affects Core Kernel: Yes
Delivery Mechanism: Direct from community
Category:	Kernel
Request Type:	Kernel - Enhancement from Upstream
d. Upstream Acceptance:	Submitted
Sponsor Priority	1
f. Severity: High
IBM Confidential:	no
Code Contribution:	IBM code
g. Component Version Target:	Patch and discussions: (Version 6)
 http://lkml.org/lkml/2009/4/16/45
 Targetting 2.6.31

3. Business Case
This framework will help move all 'movable timers' using a sysctl interface.

4. Primary contact at Red Hat: 
John Jarvis
jjarvis@redhat.com

5. Primary contacts at Partner:
Project Management Contact:
Stephanie Glass, sglass@us.ibm.com, 512-838-9284

Technical contact(s):

Vaidyanathan Srinivasan, svaidyan@in.ibm.com

IBM Manager:
Jeffrey Heroux, heroux@us.ibm.com
Comment 1 IBM Bug Proxy 2009-05-20 02:10:40 EDT
------- Comment From svaidyan@in.ibm.com 2009-05-20 02:08 EDT-------
Upstream code in sched-tip development tree.
Comment 2 IBM Bug Proxy 2009-06-17 16:51:10 EDT
------- Comment From sglass@us.ibm.com 2009-06-17 16:44 EDT-------
This is now in 2.6.31-rc kernel.

------- Comment From sglass@us.ibm.com 2009-06-17 16:45 EDT-------
This is now in 2.6.31-rc
Comment 3 IBM Bug Proxy 2010-05-10 13:21:20 EDT
------- Comment From arunbharadwaj@in.ibm.com 2010-05-10 13:14 EDT-------
Hi,

I have verified that this feature is included in RHEL6 snap1 kernel and that this feature is functionally working correct.

Here is how I have tested this feature:

On an SMP (n >= 4), all CPUs are kept idle. Run a small workload pinned to one CPU. This increases the timer interrupt rate on this CPU, and also another CPU in the same package has high interrupt rate ( equal to HZ rate). This is the ILB CPU. Now start queuing timers on another CPU using a tool called cyclictest. Due to timer migration feature, all timers from this CPU are migrated onto the ILB CPU. This verifies that the feature is functionally working correct.

thanks
arun

Note You need to log in before you can comment on or make changes to this bug.