Bug 497191 - Profiler not available
Profiler not available
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: java-1.6.0-openjdk (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Lillian Angel
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-22 14:03 EDT by Remy Maucherat
Modified: 2009-06-02 10:31 EDT (History)
4 users (show)

See Also:
Fixed In Version: 1.6.0.0-18.b16.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-29 10:10:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Error log (10.56 KB, text/plain)
2009-04-22 14:03 EDT, Remy Maucherat
no flags Details

  None (edit)
Description Remy Maucherat 2009-04-22 14:03:49 EDT
Created attachment 340781 [details]
Error log

Description of problem:
On x86_64, JFluid is not available through VisualVM.

Version-Release number of selected component (if applicable):
-19.b14

How reproducible:
Always

Steps to Reproduce:
1. Install openjdk-devel
2. Run VisualVM, which shows an error about the missing profiler
3.
  
Actual results:
There are indications that this would work on the i586 architecture.

Expected results:
VisualVM profiler is available.

Additional info:
See error log.
Comment 1 Lillian Angel 2009-04-23 13:12:12 EDT
This is unusual. I cannot reproduce it. 

can you try removing ~/.visualvm and trying again?
Comment 2 Remy Maucherat 2009-04-24 08:50:44 EDT
That did not fix it. It looks like it's a 64bit-only issue.

See org.netbeans.lib.profiler.global.Platform.getAgentNativeLibFullName(), which appends procArch = "amd64" to the path (on Linux i586, it appends nothing) which becomes /lib/visualvm/profiler3/lib/deployed/jdk16/linux-amd64, while the openjdk-devel RPM only includes /lib/visualvm/profiler3/lib/deployed/jdk16/linux

That's not the end of the problems, though, since the native libs are not there either in the 64bit package (it looks for libprofilerinterface.so, which is present in the i586 package).
Comment 3 Lillian Angel 2009-04-24 12:34:16 EDT
oh terrible. thanks for pointing this out.

i am working on it.
Comment 4 Lillian Angel 2009-04-24 14:11:56 EDT
Fixed upstream. I will close this bug when it has been updated in fedora.
Comment 5 Fedora Update System 2009-05-30 10:16:06 EDT
java-1.6.0-openjdk-1.6.0.0-18.b16.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/java-1.6.0-openjdk-1.6.0.0-18.b16.fc10
Comment 6 Fedora Update System 2009-05-30 10:17:04 EDT
java-1.6.0-openjdk-1.6.0.0-22.b16.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/java-1.6.0-openjdk-1.6.0.0-22.b16.fc11
Comment 7 Fedora Update System 2009-06-02 10:22:49 EDT
java-1.6.0-openjdk-1.6.0.0-22.b16.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2009-06-02 10:30:26 EDT
java-1.6.0-openjdk-1.6.0.0-18.b16.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.