Bug 497198 - very fast playback and roaring noise with snd_intel8x0
very fast playback and roaring noise with snd_intel8x0
Status: CLOSED DUPLICATE of bug 506075
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
11
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-22 14:43 EDT by Martin Naď
Modified: 2009-08-03 04:12 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-03 04:12:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
dmesg (36.62 KB, text/plain)
2009-04-22 15:04 EDT, Martin Naď
no flags Details
messages (1.85 MB, text/plain)
2009-04-24 04:58 EDT, Martin Naď
no flags Details
a complete output of pulseaudio -vvvv (277.71 KB, text/plain)
2009-04-24 09:02 EDT, Martin Naď
no flags Details
"/tmp/alsa-info.txt" (19.02 KB, text/plain)
2009-04-24 11:18 EDT, Martin Naď
no flags Details
"/home/NSatan/pulse.txt" (66.59 KB, text/plain)
2009-05-18 11:21 EDT, Martin Naď
no flags Details
/tmp/alsa-info.txt from second comp (18.43 KB, text/plain)
2009-08-01 15:38 EDT, Martin Naď
no flags Details
output from pulse on second comp. (231.32 KB, text/plain)
2009-08-01 15:39 EDT, Martin Naď
no flags Details
dmesg from second comp. (22.35 KB, text/plain)
2009-08-01 15:44 EDT, Martin Naď
no flags Details

  None (edit)
Description Martin Naď 2009-04-22 14:43:06 EDT
Description of problem:
pulseaudio sometime don`t work correctly.Sometimes during playback it suddenly starts playing very fast and making roaring sound.when I play some audio pusleaudio write to console this:
[NSatan@Metallica ~]$ LANG=en_IE.utf8 pulseaudio
E: alsa-sink.c: ALSA woke us up to write new data to the device, but there was actually nothing to write!
E: alsa-sink.c: Most likely this is a bug in the ALSA driver 'snd_intel8x0'. Please report this issue to the ALSA developers.
E: alsa-sink.c: We were woken up with POLLOUT set -- however a subsequent snd_pcm_avail() returned 0 or another value < min_avail.


Version-Release number of selected component (if applicable):
pulseaudio-0.9.15-10.fc11.x86_64

How reproducible:
sometime

Steps to Reproduce:
1.start pulseaudio
2.play song
3.pulseaudio very fast playback and roaring noise
  
Actual results:
pulseaudio sometime don`t work corectly with snd_intel8x0

Expected results:


Additional info:
Comment 1 Martin Naď 2009-04-22 14:45:11 EDT
Version-Release number of selected component (if applicable):
kernel-2.6.29.1-102.fc11.x86_64
Comment 2 Martin Naď 2009-04-22 15:04:16 EDT
Created attachment 340792 [details]
dmesg
Comment 3 Martin Naď 2009-04-22 15:10:57 EDT
sound card is integr. with 7 outport 1 inport
lspci: 00:10.2 Multimedia audio controller: nVidia Corporation MCP51 AC97 Audio Controller (rev a2)





The error message is shown only when using tsched=0 in the configuration.
Comment 4 Lennart Poettering 2009-04-23 17:11:06 EDT
very fast, what do you mean by that? Will it drop samples, or will it just increase the frequency?

Please provide a complete output of pulseaudio -vvvv when this happens.
Comment 5 Martin Naď 2009-04-24 04:58:09 EDT
Created attachment 341120 [details]
messages

sorry but "LANG=en_IE.utf8 pulseaudio -vvvv > pulse.txt" don`t write to txt

and pulse write to console(and more but my konsole cann`t display):
interface=org.freedesktop.Hal.Device, path=/org/freedesktop/Hal/devices/computer, member=InterfaceLockReleased 

E: cpulimit.c: Received request to terminate due to CPU overload.
12:23:41
D: protocol-native.c: Underrun on 'Audio Stream', 0 bytes in queue.                                                                                                          
D: protocol-native.c: Requesting rewind due to end of underrun.                                                                                                              
D: alsa-sink.c: Requested to rewind 65536 bytes.
Comment 6 Martin Naď 2009-04-24 09:02:49 EDT
Created attachment 341163 [details]
a complete output of pulseaudio -vvvv

I`m not in group pulse-rt fort this time
Comment 7 Martin Naď 2009-04-24 09:11:48 EDT
audio sonds like when quickly changing radio-station
Comment 8 Michal Schmidt 2009-04-24 09:27:13 EDT
From the dmesg:
intel8x0_measure_ac97_clock: measured 50831 usecs
intel8x0: clocking to 46771

The frequency looks suspicious.

And the pulseaudio log has messages like:
E: alsa-util.c: snd_pcm_avail() returned a value that is exceptionally large: 18446744073709540136 bytes (384307168172 ms).
E: alsa-util.c: Most likely this is a bug in the ALSA driver 'snd_intel8x0'. Please report this issue to the ALSA developers.

Wasn't this supposed to be fixed already in ALSA? Martin has kernel 2.6.29.1-102.fc11.x86_64.
Comment 9 Lennart Poettering 2009-04-24 11:04:07 EDT
Use &> instead of > to redirect the PA log output to a file.

Given those intel8x0_measure_ac97_clock and snd_pcm_avail() lines this seems to be a driver issue.

Reassigning to kernel.

Martin, please paste the output of alsa-info.sh --no-upload here.
Comment 10 Martin Naď 2009-04-24 11:18:06 EDT
Created attachment 341190 [details]
"/tmp/alsa-info.txt"
Comment 11 Martin Naď 2009-05-18 10:13:22 EDT
after a few updates to this bug deteriorated, pulseaudio delay sound, pulse very often crash
Comment 12 Martin Naď 2009-05-18 11:21:16 EDT
Created attachment 344454 [details]
"/home/NSatan/pulse.txt"

new pulseaudio --vvvv output,for this time without crash
Comment 13 Martin Naď 2009-05-18 12:32:00 EDT
from mplayer:
[pulse] working around probably broken pause functionality,
        see http://www.pulseaudio.org/ticket/440
AO: [pulse] 48000Hz 2ch s16le (2 bytes per sample)
Comment 14 Bug Zapper 2009-06-09 10:25:37 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 15 Martin Naď 2009-08-01 15:35:21 EDT
I reproduce this bug on other computer signifies like on my computer.
Comment 16 Martin Naď 2009-08-01 15:38:35 EDT
Created attachment 355890 [details]
/tmp/alsa-info.txt from second comp

alsa-info from second comp.
Comment 17 Martin Naď 2009-08-01 15:39:50 EDT
Created attachment 355891 [details]
output from pulse on second comp.

output from pulse on second comp.
Comment 18 Martin Naď 2009-08-01 15:42:47 EDT
Version-Release number of selected component (if applicable):

xine-lib-pulseaudio-1.1.16.3-2.fc11.x86_64
pulseaudio-module-x11-0.9.15-14.fc11.x86_64
pulseaudio-utils-0.9.15-14.fc11.x86_64
alsa-plugins-pulseaudio-1.0.20-2.fc11.x86_64
pulseaudio-libs-0.9.15-14.fc11.x86_64
kde-settings-pulseaudio-4.2-10.20090430svn.fc11.noarch
pulseaudio-0.9.15-14.fc11.x86_64
pulseaudio-libs-glib2-0.9.15-14.fc11.x86_64
kernel-2.6.29.6-217.2.3.fc11.x86_64
Comment 19 Martin Naď 2009-08-01 15:44:37 EDT
Created attachment 355892 [details]
dmesg from second comp.

dmesg from second comp.
Comment 20 Martin Naď 2009-08-02 13:39:54 EDT
this bug is in other distribution
gentoo:
http://bugs.gentoo.org/119015
zubuntu:
http://www.mail-archive.com/ubuntu-bugs@lists.ubuntu.com/msg1558165.html
Comment 21 Lubomir Rintel 2009-08-03 04:12:31 EDT
(In reply to comment #8)
> From the dmesg:
> intel8x0_measure_ac97_clock: measured 50831 usecs
> intel8x0: clocking to 46771
> 
> The frequency looks suspicious.
> 
> And the pulseaudio log has messages like:
> E: alsa-util.c: snd_pcm_avail() returned a value that is exceptionally large:
> 18446744073709540136 bytes (384307168172 ms).
> E: alsa-util.c: Most likely this is a bug in the ALSA driver 'snd_intel8x0'.
> Please report this issue to the ALSA developers.
> 
> Wasn't this supposed to be fixed already in ALSA? Martin has kernel
> 2.6.29.1-102.fc11.x86_64.  

The frequency detection was reworked seems to have been reworked for 2.6.31, the snd_pcm_avail() bug as well, see bug #506075 for isolated patches.

*** This bug has been marked as a duplicate of bug 506075 ***

Note You need to log in before you can comment on or make changes to this bug.