Bug 49720 - rpmlint errors on the nautilus package
rpmlint errors on the nautilus package
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: nautilus (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Owen Taylor
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-23 11:24 EDT by Panic
Modified: 2007-04-18 12:35 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-24 00:08:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
rpmlint errors from nautilus-1.0.4-11 (3.17 KB, text/plain)
2001-07-23 11:25 EDT, Panic
no flags Details

  None (edit)
Description Panic 2001-07-23 11:24:17 EDT
Description of Problem:

rpmlint comes back with a series of errors (mostly small stuff) on the
nautilus-1.0.4-11 rpm in beta2.  The full file is attached, the two I think
are most important are:

E: nautilus postin-without-ldconfig /usr/lib/libnautilus-adapter.so.0.0.0
E: nautilus postun-without-ldconfig /usr/lib/libnautilus-adapter.so.0.0.0

E: nautilus postin-without-ldconfig /usr/lib/libnautilus-private.so.0.0.0
E: nautilus postun-without-ldconfig /usr/lib/libnautilus-private.so.0.0.0

E: nautilus postin-without-ldconfig /usr/lib/libnautilus.so.0.0.0
E: nautilus postun-without-ldconfig /usr/lib/libnautilus.so.0.0.0

E: nautilus postin-without-ldconfig /usr/lib/libnautilus-tree-view.so.0.0.0
E: nautilus postun-without-ldconfig /usr/lib/libnautilus-tree-view.so.0.0.0

E: nautilus invalid-lc-messages-dir
/usr/share/locale/nn/LC_MESSAGES/nautilus.mo

E: nautilus invalid-shell-in-%postun /sbin/ldconfig

These seem to be caused by the scripts in the rpm itself:

************

#rpm -q --scripts nautilus

postinstall scriptlet (through /bin/sh):
if ! grep /usr/lib /etc/ld.so.conf > /dev/null ; then
        echo "/usr/lib" >> /etc/ld.so.conf
fi
scrollkeeper-update
postuninstall scriptlet (through /sbin/ldconfig):
scrollkeeper-update

*************

From what I know, the "through" specifier should be a shell, not ldconfig.
 Also, these scripts don't seem to apply properly to what is occuring
during the rpm installation -- the libraries are added/removed in /usr/lib,
but running scrollkeeper-update doesn't run ldconfig (from what I can tell)
nor does it deal with /usr/lib -- it updates the configured OMF directory,
which from scrollkeeper-config is /usr/share/omf.

Also, the check simply looks for the string "/usr/lib", which in this case
is *not* present in the /etc/ld.so.conf by itself (another bug in and of
itself?  Change in defaults?).  However, the grep check succeeds because
there are several directories in /etc/ld.so.conf that contain the string
/usr/lib as part of their directory name.  In other words, the grep check
is too simplistic and does not achieve the apparently desired result, which
furthermore may be undesireable behavior.

I'm not sure why rpmlint returns an "invalid-lc-messages-dir", but it
appears to be installing something for a locale that we don't support --
not a big deal, but probably should be fixed.  What locale is "nn" anyway?
 Is this just a typo for "no"?  It does appear to be the norwegian entry,
from looking at the nautilus.mo file dropped in the directory, but there is
already a nautilus.mo file in the "no" directory.  The two files do appear
to differ.

How Reproducible:

Always

Steps to Reproduce:
1. Run rmplint against the nautilus package
2. view errors
3. 

Actual Results:

Some low-grade errors and warnings, along with some strange and more
serious errors.  The rpm scripts seem to be broken in several places.

Expected Results:

return only low-grade errors and warnings, rpm scripts function properly
and do the job they are supposed to do.

Additional Information:
Comment 1 Panic 2001-07-23 11:25:27 EDT
Created attachment 24607 [details]
rpmlint errors from nautilus-1.0.4-11
Comment 2 Glen Foster 2001-07-23 17:12:43 EDT
This defect is considered MUST-FIX for Fairfax.
Comment 3 Owen Taylor 2001-07-24 00:06:55 EDT
the -p problems are just people not understanding the 
%postun -p "hack".

nn is a standard language - it's the Nynorsk dialect of Norwegian.

Fixing in nautilus-1.0.4-15
Comment 4 Owen Taylor 2001-07-24 00:08:39 EDT
That was probably unclear - what I meant by -p is that the person
who wrote the spec file originally didn't understand it, I'm
fixing it now.
Comment 5 Owen Taylor 2001-07-30 15:17:47 EDT
Should be fixed now.

Note You need to log in before you can comment on or make changes to this bug.