Bug 497239 - IndexError: list index out of range
IndexError: list index out of range
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
: 498745 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-22 18:46 EDT by Clyde E. Kunkel
Modified: 2009-05-04 11:42 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 497237
Environment:
Last Closed: 2009-04-24 14:12:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda traceback: IndexError: list index out of range (968.20 KB, text/plain)
2009-04-22 18:46 EDT, Clyde E. Kunkel
no flags Details

  None (edit)
Description Clyde E. Kunkel 2009-04-22 18:46:22 EDT
Created attachment 340846 [details]
anaconda traceback: IndexError: list index out of range

+++ This bug was initially created as a clone of Bug #497237 +++
CryptoError: luks_open failed for /dev/mapper/VolGroup02-fedora11x64

Description of problem:
traceback when trying to edit unsuccessful format and encryption of VolGroup02-fedora11x64

Version-Release number of selected component (if applicable):
anaconda-11.5.0.47

How reproducible:
didn't try

Steps to Reproduce:
1. boot.iso, askmethod
2. install.img from download.fedora.redhat.com
3. custom paritioning
4. During storage device scan, found LV fedora11x64 and requested pass phrase.
5. Passphrase was not accepted, so clicked cancel
5. LV fedora11x64 showed in custom partitioning, but when clicked ok after editing it, traceback occurred.
  
Actual results:
traceback

Expected results:
Should be able to treat the luks parition as if starting from scratch, even tho the request for pass phrase failed during storage detection.

Additional info:
If the expected results above conflicts with design objectives, then there still should not be a traceback, but rather a dialogue allowing other actions including deleting the LV and recreating it.  I am going to try the install again and this time will select delete the parition instead of editing it and then try to recreate it.
Comment 1 Clyde E. Kunkel 2009-04-22 19:34:13 EDT
Same error when trying to delete the LV.  It must be in an indeterminate state.  However, should be able to delete it, recreate it, and then get on with things.
Comment 2 Chris Lumens 2009-04-24 14:12:56 EDT
This should be fixed in the next build of anaconda.  Thanks for the bug report.
Comment 3 Chris Lumens 2009-05-04 11:42:17 EDT
*** Bug 498745 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.