Bug 497253 - Anaconda crashes while creating a custom layout with swap in KVM.
Anaconda crashes while creating a custom layout with swap in KVM.
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
anaconda_trace_hash:260456ae7b615b10a...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-22 22:07 EDT by Gideon Mayhak
Modified: 2009-06-12 11:10 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-06 00:13:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (257.89 KB, text/plain)
2009-04-22 22:07 EDT, Gideon Mayhak
no flags Details
Attached traceback automatically from anaconda. (108.29 KB, text/plain)
2009-06-12 11:10 EDT, Chris
no flags Details

  None (edit)
Description Gideon Mayhak 2009-04-22 22:07:07 EDT
The following was filed automatically by anaconda:
anaconda 11.5.0.47 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/storage/devicelibs/swap.py", line 46, in mkswap
    raise SwapError("mkswap failed for '%s'" % device)
  File "/usr/lib/anaconda/storage/formats/swap.py", line 142, in create
    swap.mkswap(self.device, label=self.label)
  File "/usr/lib/anaconda/storage/deviceaction.py", line 273, in execute
    options=self.device.formatArgs)
  File "/usr/lib/anaconda/storage/devicetree.py", line 659, in processActions
    action.execute(intf=self.intf)
  File "/usr/lib/anaconda/storage/__init__.py", line 234, in doIt
    self.devicetree.processActions()
  File "/usr/lib/anaconda/packages.py", line 117, in turnOnFilesystems
    anaconda.id.storage.doIt()
SwapError: mkswap failed for '/dev/vda2'
Comment 1 Gideon Mayhak 2009-04-22 22:07:15 EDT
Created attachment 340854 [details]
Attached traceback automatically from anaconda.
Comment 2 Gideon Mayhak 2009-04-22 22:10:56 EDT
This happened while trying to do an install of rawhide into a KVM virtual machine.  The following is an approximation of the layout I chose:

/dev/vda1    /boot    128MB
/dev/vda2    swap     1024MB
/dev/vda3    /        the rest

This was on a 10G qcow2 disk image that was initialized at the beginning of the Anaconda session.  /boot was ext3 and / was btrfs.  It appears the crash happened during mkswap.
Comment 3 Gideon Mayhak 2009-04-22 22:21:28 EDT
I tried again, letting it create the default layout (though I changed / from ext4 to btrfs).  It still crashes, but this time with pvcreate for /dev/sda2.  I'm going to try once more, simply letting it do the default layout with no changes.
Comment 4 Gideon Mayhak 2009-04-22 22:30:35 EDT
Still crashes, so it definitely had nothing to do with btrfs.  And that should say /dev/vda2.
Comment 5 Chris Lumens 2009-04-23 09:44:41 EDT
Whatever kind of device /dev/vda is, you are experiencing a rather serious problem with it.  There are tons of messages like these in your error log:

<3>end_request: I/O error, dev vda, sector 97
<3>Buffer I/O error on device vda1, logical block 12
<4>lost page write due to I/O error on vda1
<3>end_request: I/O error, dev vda, sector 105
<3>end_request: I/O error, dev vda, sector 113
<3>end_request: I/O error, dev vda, sector 121
<3>end_request: I/O error, dev vda, sector 145
Comment 6 Gideon Mayhak 2009-04-24 21:05:14 EDT
It's just a qcow2 file sitting on my Fedora 10 partition (ext3).  I've used the same to install rawhide before and it worked (maybe a week or so ago).  Here's the command I used to create the qcow2 file:

qemu-img create -f qcow2 gidux-kvm-rawhide-kde.qcow2 10G

Do you think those errors could be indicative of an issue I should investigate with my hard drive?  Could a KVM virtual machine see that far into the host, so to speak?  Palimpset says my laptop drive is okay, and I haven't been having issues.  Otherwise, do you think there's an issue with qcow2 handling?
Comment 7 Gideon Mayhak 2009-05-16 16:18:13 EDT
Do you have any thoughts on this?  As I said before, I'm not accessing a physical device, but a file.  Would it still see errors related to the physical device that the file is on, or could this be an indication of a bug in the qcow2 driver?

Once F11 final is out, I plan on doing a fresh install and formatting my main partition with ext4, so I'll be able to try this again with the qcow2 file on an ext4 / partition instead of ext3 (though, I would think we'd want the same behavior regardless of the filesystem).
Comment 8 Gideon Mayhak 2009-05-25 23:16:49 EDT
The installer does not crash if my layout does not include a swap partition.
Comment 9 Gideon Mayhak 2009-06-03 22:18:08 EDT
I know this won't necessarily help identify the problem, but I wanted to note that I am currently installing Fedora 11 Preview in VirtualBox 2.2.4 OSE (from RPM Fusion), with the default partition layout, and Anaconda did not error out.  The virtual disk is on my ext3 partition.
Comment 10 Gideon Mayhak 2009-06-06 00:13:49 EDT
I just tried once more, and it worked this time!  I noticed there were updates to libvirt and virt-manager today, so I don't know if those are related, but it appears to be working now.  I'm counting this closed.
Comment 11 Chris 2009-06-12 11:10:32 EDT
Created attachment 347584 [details]
Attached traceback automatically from anaconda.

Note You need to log in before you can comment on or make changes to this bug.