Bug 497274 - goo_canvas_widget_new () does not seem to work
goo_canvas_widget_new () does not seem to work
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: goocanvas (Show other bugs)
11
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bernard Johnson
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 493250
  Show dependency treegraph
 
Reported: 2009-04-23 02:21 EDT by Mamoru TASAKA
Modified: 2010-11-01 11:28 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-28 08:10:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
gdb log to show where widgets-demo hangs (4.80 KB, text/plain)
2009-04-23 02:21 EDT, Mamoru TASAKA
no flags Details
gdb log (2.72 KB, text/plain)
2009-05-06 09:40 EDT, Pawel Greipner
no flags Details

  None (edit)
Description Mamoru TASAKA 2009-04-23 02:21:09 EDT
Created attachment 340874 [details]
gdb log to show where widgets-demo hangs

Description of problem:
With goocanvas-0.13-2.fc11, demo/widgets-demo hangs.

It seems in demo/widget-demo.c,
------------------------------------------------------------
   364    witem = goo_canvas_widget_new (root, label, 50, 50, 200, 100, NULL);
------------------------------------------------------------
never returns. Something is going wrong with goo_canvas_widget_new().


Version-Release number of selected component (if applicable):
goocanvas-0.13-2.fc11

How reproducible:
100%

Steps to Reproduce:
1. cd ~/rpmbuild/SRPMS ; rpm -ivh goocanvas-0.13-2.fc11.src.rpm
2. cd ../SPECS ; rpmbuild -bc goocanvas.spec
3. cd ../BUILD/goocanvas-0.13/demo ; make
4  ./widgets-demo
  
Actual results:
demo-widget hangs

Expected results:
goocanvas-0.10-2.fc10 demo/demo-widget works

Additional info:
gdb log attached
Comment 1 Mamoru TASAKA 2009-04-23 02:33:49 EDT
Note:
Current goocanvas seems 0.14, however even with 0.14 demo/widgets-demo
does not work.
Comment 2 Denis Leroy 2009-04-23 04:05:53 EDT
Hi!

well it works for me, widgets-demo works ok and does not hang on goo_canvas_widget_new...... I've only tried with goocanavas 0.14, which I'm about to push to updates. pitivi and conduit seem happy with the update, as far as I can tell. All the demos seem to work ok.
Comment 3 Mamoru TASAKA 2009-04-23 05:27:07 EDT
(In reply to comment #2)
> Hi!
> 
> well it works for me, widgets-demo works ok and does not hang on
> goo_canvas_widget_new...... I've only tried with goocanavas 0.14, which I'm
> about to push to updates. pitivi and conduit seem happy with the update, as far
> as I can tell. All the demos seem to work ok.  

Hello.

From gdb logs I guess this is at-spi related (although
I don't know exactly what at-spi actually does).
Would you examine if widgets-demo works even if
- You are using GNOME desktop environment
- And you have "Assistive Technologies" enabled ?
  ! On F-11 at-spi "Assistive Technologies" can be enabled from
    "GNOME panel" -> "System" -> "Preferences" -> "Assistive Technologies"
Actually when I disabled "Assistive Technologies" widgets-demo works.
Comment 4 Martin-Gomez Pablo 2009-05-02 14:09:05 EDT
I've followed the instruction with and without "Assistive Technologies" and widgets-demo works well using goocanavas-0.13.2. But I made it with my "builder" user so it doesn't use gnome (terminal user only).
Comment 5 Pawel Greipner 2009-05-06 09:40:25 EDT
Created attachment 342643 [details]
gdb log

I get the same thing with version 0.14 and 0.12, didn't try 0.13.
I'm running it on Ubuntu 8.10 and GNOME.
Comment 6 Bug Zapper 2009-06-09 10:27:03 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 7 Bug Zapper 2010-04-27 09:53:29 EDT
This message is a reminder that Fedora 11 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 11.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '11'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 11's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 11 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 Bug Zapper 2010-06-28 08:10:43 EDT
Fedora 11 changed to end-of-life (EOL) status on 2010-06-25. Fedora 11 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.
Comment 9 Patrick Monnerat 2010-11-01 11:28:31 EDT
This bug should be reopened because it still affects Fedora 12 (did not try > 12).
This prevents openshot (ready for rpmfusion) from working if Assistive Technologies are enabled (issues the same error message as the widget_demo program and hangs).
Probably atk-related: this bug should then be also reassigned in this case.

Note You need to log in before you can comment on or make changes to this bug.