Bug 497275 - Python based plasmoids under KDE4
Python based plasmoids under KDE4
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kdebase-workspace (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-23 02:50 EDT by Zarko (grof)
Modified: 2009-04-23 12:59 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-23 08:51:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zarko (grof) 2009-04-23 02:50:18 EDT
Description of problem:
When user wants to install Python based plasmoid under KDE4 the issue occur.
Plasmoid can not works at all, and user can not simply resolve this problem.

Version-Release number of selected component (if applicable):


How reproducible:
Python based plasmoids do not work out-of-the-box

Steps to Reproduce:
Try install this one:
http://code.google.com/p/gmail-plasmoid/
then,
plasmapkg -i gmail-plasmoid-0.6.5.plasmoid
and at the end, try to start them.
You'll get this message:
This object could not be created for the following reason:
Could not create a python Scriptengine for the gmail-plasmoid widget
  
Resolving:
This can be simply resolved installing this package by default with KDE environment:
kdebase-workspace-python-applet
Comment 1 Rex Dieter 2009-04-23 07:27:45 EDT
yum install kdebase-workspace-python-applet
Comment 2 Zarko (grof) 2009-04-23 07:41:19 EDT
(In reply to comment #1)
> yum install kdebase-workspace-python-applet  

Yes, I know that :), but many users do not (because do not know which package they must install for this kind of plasmoids).

Could be possible to include this package into KDE Group or as Requires into kdebase-workspace's .spec file (in the future), so it will be automatically installed with other KDE base staff, or on some other way?
Comment 3 Rex Dieter 2009-04-23 08:51:11 EDT
We can and should add it to KDE Group, sure.
Comment 4 Kevin Kofler 2009-04-23 12:59:59 EDT
A Requires would be stupid, it'd defeat the whole point of making it a subpackage.

Note You need to log in before you can comment on or make changes to this bug.