Bug 49732 - raidstop always fails on /dev/md0
Summary: raidstop always fails on /dev/md0
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: raidtools (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Doug Ledford
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-07-23 16:15 UTC by Kees Cook
Modified: 2007-04-18 16:35 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-27 22:40:06 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Kees Cook 2001-07-23 16:15:44 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)

Description of problem:
Trying to run "raidstop /dev/md0" will always report that the raid is 
still in use.

How reproducible:
Always

Steps to Reproduce:
1. create and start a raid on /dev/md0
2. run "raidstop /dev/md0"
3. poof, error.
	

Actual Results:  raidstop claims that md0 is still in use.

Expected Results:  Raid should stop.

Additional info:

It looks like the raidtools are doing a version check on the md driver 
(version.c), but for some reason, the "close" has been commented out, and 
this leaves /dev/md0 open, which increases the usage counter in the md 
driver, so that the "stop" IOCTL will fail.

I worked around this by hex-editing raidstop (I didn't have the source at 
the time) to use /dev/md1 for version checking (it's hardcoded in the 
source).  This left the counters for md0 untouched, and I was able to stop 
the raid.

This is a serious problem for anyone working with raids where the raid 
does not live from boot to boot.

Comment 1 Arjan van de Ven 2001-12-06 20:58:15 UTC
Weird.. I do mkraid/raidstart and later raidstop a lot and it never fails for me
unless a filesystem is mounted...


Note You need to log in before you can comment on or make changes to this bug.