Bug 497343 - audit2allow -a does not find denials in /var/log/messages
audit2allow -a does not find denials in /var/log/messages
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: policycoreutils (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-23 09:34 EDT by Eric Paris
Modified: 2009-04-24 14:05 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-24 14:05:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Paris 2009-04-23 09:34:11 EDT
I had a number of denials before auditd started and I have denials from dbus, both of which show up in /var/log/messages

I run audit2allow -a and I don't get any rules.

I run cat /var/log/messages | audit2allow and I get my allow rules

An example /var/log/messages can be provided if needed, but it doesn't seem to matter if the logging is from dbus or from kernel....
Comment 1 Daniel Walsh 2009-04-24 14:05:48 EDT
Fixed in  policycoreutils-2.0.62-12.1

Note You need to log in before you can comment on or make changes to this bug.