Bug 497352 - Tried to use undefined partition pv.01 in Volume Group specification.
Tried to use undefined partition pv.01 in Volume Group specification.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Radek Vykydal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-23 10:37 EDT by James Laska
Modified: 2013-09-02 02:35 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-27 07:33:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda-logs.tgz (/tmp/*log, ks.cfg) (16.44 KB, application/octet-stream)
2009-04-23 10:37 EDT, James Laska
no flags Details

  None (edit)
Description James Laska 2009-04-23 10:37:47 EDT
Created attachment 340945 [details]
anaconda-logs.tgz (/tmp/*log, ks.cfg)

Description of problem:
Performing a kickstart install to test https://fedoraproject.org/wiki/QA/TestCases/PartitioningRaid0OnLvmDevice fails with a kickstart failure.  This could be a problem with my kickstart, but it appears sane to me.


Version-Release number of selected component (if applicable):
anaconda-11.5.0.47

How reproducible:


Steps to Reproduce:
1. Initiate a kickstart install to test RAID using LVM logical volumes
  
Actual results:

------| Error Parsing Kickstart Config |--------
The following error was found while parsing your 
kickstart configuration:

The following problem occured on line 34 of the
kickstart file:

Tried to use undefined partition pv.01 in Volume
Group specification.
------------------------------------------------

Expected results:


Additional info:
Comment 1 James Laska 2009-04-23 10:41:06 EDT
From the attached anaconda-logs.tgz, the kickstart file looks like:

#version=F10
# Firewall configuration
firewall --disabled
# Root password
rootpw --iscrypted $1$xafj7qlW$6swjxMwu0po47drJVRcIZ/
# System keyboard
keyboard us
# System language
lang en_US
# Installation logging level
logging --level=info
# Use network installation
url --url=http://download.fedora.devel.redhat.com/pub/fedora/linux/development/x86_64/os
# Reboot after installation
reboot
# System timezone
timezone --isUtc America/New_York
# System bootloader configuration
bootloader --location=mbr
# Partition clearing information
clearpart --all --initlabel 
# Disk partitioning information
part /boot --asprimary --fstype="ext3" --size=200 --label=BOOT
part swap --fstype="swap" --recommended --label=SWAP
part raid.01 --grow --size=2048
part raid.02 --grow --size=2048
part pv.02 --size=2048
raid pv.01  --device=0 --fstype="ext3" --level=RAID0 raid.01 raid.02
volgroup LVMONRAID --pesize=32768 pv.01 pv.02
logvol /  --fstype="ext3" --grow --size=2048 --name=root --vgname=LVMONRAID
Comment 2 Radek Vykydal 2009-04-24 03:18:30 EDT
I reproduced the bug and prepared a patch which works for me.
Can you test if http://fedorapeople.org/~rvykydal/updates.497352.img
fixes it for you too? (Updates is against .47 version)
Comment 3 James Laska 2009-04-24 09:28:56 EDT
Thanks Radek, the updates.img provided resolves the issue.

The reproducer was:
 1) Perform an autopart kickstart install that uses
    clearpart --all --initlabel
    zerombr
    %pre to dd the first 512 of drive
 2) Perform lvm_on_raid kickstart install using kickstart provided in comment#1
Comment 4 Radek Vykydal 2009-04-27 07:33:58 EDT
This should be fixed in version 11.5.0.49-1 of anaconda.

Note You need to log in before you can comment on or make changes to this bug.