Bug 497372 - Splash Screen on boot at wrong resolution with KDE
Splash Screen on boot at wrong resolution with KDE
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: solar-kde-theme (Show other bugs)
rawhide
i386 Linux
low Severity low
: ---
: ---
Assigned To: Jaroslav Reznik
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-23 11:30 EDT by danielerusso
Modified: 2009-04-24 11:34 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-24 04:51:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
here's the screenshot of the problem (268.64 KB, image/jpeg)
2009-04-24 09:10 EDT, danielerusso
no flags Details

  None (edit)
Description danielerusso 2009-04-23 11:30:17 EDT
Description of problem:
I am using a KDE Fedora 11 Beta Live mounted on an Usb stick with liveusb creator.During the boot the splash screen (that one with sun and sky) is not shown at the best resolution.Instead of full screen it is shown in a correct resolution (I mean not stretched) in a rectangle on the left.I do not have the same issue in the Gnome version of this beta.My best resolution should be 1280x800.I have an Asus F6a laptop with an Intel X4500HD.

Version-Release number of selected component (if applicable):Kde Fedora 11 Beta


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jaroslav Reznik 2009-04-23 11:41:42 EDT
Do you mean Solar theme (blue "sun" and blue "sky")? Solar theme should be matching screen resolution correctly, I'm using it with 1280x800 resolution without any problems... You can try latest Leonidas KDE theme - it's theme for Fedora 11.

If it is really Solar theme I'll reassign to proper component solar-kde-theme.
Comment 2 danielerusso 2009-04-24 03:27:52 EDT
Yes,I mean blue sun with a starred sky that appears just before the "normal" desktop.Normal desktop has the same image as wallpaper,but that works fine for me....the problem is the boot one!I don't have the same issue with gnome version of Fedora Beta(greek acropolis image).I reported this bug because maybe this could be a KMS related problem,not depending on the image itself,but on a wrong resolution detection..I've used the iso of latest Beta released of fedora 11.Thank you
Comment 3 Jaroslav Reznik 2009-04-24 04:51:31 EDT
Hmm,
I'm not sure what's wrong as we do not use images with smaller resolution than your native resolution (1280x800). And I can't reproduce it on my 1280x800 laptop neither. KSplashX matches best resolution according to aspect ratio, so for widescreen it should pick up 1920x1200 wallpaper and resize it to this smaller (but widescreen) resolution. 

Thanks for report but I'll close this bug as "works for me" as I can't reproduce it and it's working properly on all my computers with lot of different resolutions. Please try F11 preview once it's released and feel free to reopen this bug if it won't be solved. Maybe there's really some X issue and there's big progress on gfx drivers side since beta.
Comment 4 danielerusso 2009-04-24 09:10:28 EDT
Created attachment 341165 [details]
here's the screenshot of the problem
Comment 5 danielerusso 2009-04-24 09:12:05 EDT
ok,I'll test Preview release the 28th of this month! :)
Comment 6 Kevin Kofler 2009-04-24 11:34:40 EDT
KSplash doesn't pick the closest aspect ratio, it picks only exactly matching ones, and if no match, the largest it can find, which is a 4:3 one. :-(

Maybe something changed in KSplash to make it no longer stretch the wallpapers to different aspect ratios? (I'll have to look at the code.)

Note You need to log in before you can comment on or make changes to this bug.