Bug 49738 - If 'fdisk' is used to create partitions during install, user is unable to assign mount points later during installation
Summary: If 'fdisk' is used to create partitions during install, user is unable to ass...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 7.3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Brent Fox
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-07-23 16:37 UTC by Bryan Leopard
Modified: 2007-04-18 16:35 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-01 20:18:27 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bryan Leopard 2001-07-23 16:37:57 UTC
HW:

ProLiant DL360
-(2) 933 Mhz PIII processors
-128 MB RAM
-Integrated Array controller with ROC f/w version 1.46 enabled as primary 
(boot) controller
-(2) 18.2 GB Ultra2 drives configured as (1) logical RAID 1 volume (OS 
boot drive)

SW:

Red Hat Fairfax - Beta 2

STEPS TAKEN TO ENCOUNTER PROBLEM:

-Manually configure DL360 with a current version of Smart Start, this will 
leave a 36 MB Compaq System Utilities partition

-Boot to CD 1 of Red Hat Beta 2 and proceed through the installation 
interview to the Disk Partitioning Setup screen where you are given 3 disk 
partitioning options: Auto-partitioning, Manual - Disk Druid, Manual - 
fdisk.

-Choose to "Manually partition with fdisk [experts only]"

-At the 'fdisk' screen, select 'ida/c0d0' as the drive to run fdisk on

-While running fdisk, create a partition table that looks like the 
following:

              Device   Boot  Start  End    Blocks       Id  System
              -----------   -------   -------  -------   ----------
        ---  ------------
/tmp/ida/c0d0p1    *       10     22     53040       83  Linux
/tmp/ida/c0d0p2             23    87     265200     82  Linux Swap
/tmp/ida/c0d0p3             1      9       36704       12  Compaq Diag
/tmp/ida/c0d0p4              88   4357  17421600 82 Linux

-Note: all partitions above are configured as primary partitions

-Write the partition table above to the disk

-Proceed to the "Disk Setup" screen where we can try to edit the mount 
points

-At the "Disk Setup" screen, we see the following partition table 
displayed:

         Device          Start   End   Size(MB)   Type
         -----------          --------   ------   --------------   --------
/dev/ida/c0d0p3	 1        9          36          vfat
/dev/ida/c0d0p1    10       22         52        None
/dev/ida/c0d0p2     23      87        259       None
/dev/ida/c0d0p4     88     4357     17013   None

-Note: I was intending for /dev/ida/c0d0p1 to be my '/boot' 
partition/filesystem, /dev/ida/c0d0p2 to be my 'swap' partition/filesystem 
and /dev/ida/c0d0p4 to be my '/' filesystem partition.

-Highlight /dev/ida/c0d0p1 and select 'Edit' from the "Disk Setup" menu

-Note that the Mount Point selection is "grayed-out".  I'm unable to 
select any moint points or manually edit them here.

-The "Original Filesystem Type" is listed as "Foreign" as well

-The Size(MB) field shows a size of 51 MB, which is inconsistent with what 
fdisk reported earlier

-Select the /dev/ida/c0d0p4 partition and attempt to edit it.

-Note that you cannot edit mount points here either.

-I need to delete the 'fdisk-created' partitions and manually partition 
with Disk Druid in order to proceed.

NOTE: Disk Druid works.

Comment 1 Michael Fulbright 2001-07-23 18:37:37 UTC
Please retry with beta 3 - it should work now.

Comment 2 Glen Foster 2001-07-23 21:13:18 UTC
This defect is considered MUST-FIX for Fairfax.

Comment 3 Bryan Leopard 2001-08-01 20:18:22 UTC
This is fixed in Beta 3.  YOu can close this bug.


Note You need to log in before you can comment on or make changes to this bug.