Bug 497390 - autopart puts PReP and '/boot' on different disks
autopart puts PReP and '/boot' on different disks
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F11AnacondaBlocker
  Show dependency treegraph
 
Reported: 2009-04-23 13:06 EDT by James Laska
Modified: 2013-09-02 02:35 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-06 17:24:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description James Laska 2009-04-23 13:06:42 EDT
Description of problem:
On an IBM power5 system, autopart puts the PReP and '/boot' partitions on different disk.  Due to a yaboot limitation (I think), these partitions must exist on the same disk.

Version-Release number of selected component (if applicable):
anaconda-11.5.0.47

How reproducible:
every autopart install

Steps to Reproduce:
https://fedoraproject.org/wiki/QA:Testcase_Anaconda_autopart_install
  
Actual results:
While partitioning will work, yaboot is unable to boot in such a scenario.

Expected results:
In F10 and RHEL5, PReP and '/boot' are always on the same disk (typically sda1 and sda2).

Additional info:
Comment 1 Chris Lumens 2009-05-05 15:30:00 EDT
This should be fixed in the next build of anaconda.  Thanks for the bug report.
Comment 2 Chris Lumens 2009-05-06 17:24:44 EDT
Actually, I tested this on ppc as well, so moving to CLOSED.

Note You need to log in before you can comment on or make changes to this bug.