Bug 497397 - PackageKit exception
PackageKit exception
Status: CLOSED DUPLICATE of bug 495087
Product: Fedora
Classification: Fedora
Component: PackageKit (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
: 500699 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-23 14:21 EDT by Christopher Aillon
Modified: 2009-06-17 16:02 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-17 16:02:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christopher Aillon 2009-04-23 14:21:27 EDT
% rpm -qa *ackage*it*
PackageKit-0.4.6-4.fc11.x86_64
PackageKit-glib-0.4.6-4.fc11.x86_64
PackageKit-gstreamer-plugin-0.4.6-4.fc11.x86_64
PackageKit-yum-plugin-0.4.6-4.fc11.x86_64
PackageKit-yum-0.4.6-4.fc11.x86_64
PackageKit-gtk-module-0.4.6-4.fc11.x86_64
gnome-packagekit-2.27.2-0.2.20090414git.fc11.x86_64
%

Did an update today and it failed with:

Error Type: <type 'exceptions.TypeError'>
Error Value: rpmdb open failed
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 2804, in <module>
    main()
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 2800, in main
    backend = PackageKitYumBackend('', lock=True)
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 197, in __init__
    self.yumbase = PackageKitYumBase(self)
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 2743, in __init__
    self.repos.confirm_func = self._repo_gpg_confirm
  File : /usr/lib/python2.6/site-packages/yum/__init__.py, line 643, in <lambda>
    repos = property(fget=lambda self: self._getRepos(),
  File : /usr/lib/python2.6/site-packages/yum/__init__.py, line 448, in _getRepos
    self.conf # touch the config class first
  File : /usr/lib/python2.6/site-packages/yum/__init__.py, line 649, in <lambda>
    conf = property(fget=lambda self: self._getConfig(),
  File : /usr/lib/python2.6/site-packages/yum/__init__.py, line 239, in _getConfig
    self._conf = config.readMainConfig(startupconf)
  File : /usr/lib/python2.6/site-packages/yum/config.py, line 794, in readMainConfig
    yumvars['releasever'] = _getsysver(startupconf.installroot, startupconf.distroverpkg)
  File : /usr/lib/python2.6/site-packages/yum/config.py, line 867, in _getsysver
    idx = ts.dbMatch('provides', distroverpkg)
Comment 1 Richard Hughes 2009-06-03 04:28:09 EDT
It looks like your rpmdb is broken, which isn't the fault of PackageKit. yum
has thrown the error TypeError, which isn't also helpful. Is this fixed if you
reboot, or clear the rpmdb locks manually?
Comment 2 Richard Hughes 2009-06-03 04:39:48 EDT
*** Bug 500699 has been marked as a duplicate of this bug. ***
Comment 3 Bug Zapper 2009-06-09 10:28:33 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Christopher Aillon 2009-06-17 16:02:54 EDT
Think this was caused by whatever caused bug 495087... so duping even though that bug is against yum, it seems that the newer PK rpms were used to resolve that bug per https://fedorahosted.org/rel-eng/ticket/1628

*** This bug has been marked as a duplicate of bug 495087 ***

Note You need to log in before you can comment on or make changes to this bug.