Bug 497412 - qpid-cluster tool stack traces are not helpful
qpid-cluster tool stack traces are not helpful
Status: CLOSED DUPLICATE of bug 498247
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-qmf (Show other bugs)
1.1.1
All Linux
low Severity low
: 1.3
: ---
Assigned To: Nuno Santos
MRG Quality Engineering
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-23 15:31 EDT by Alan Conway
Modified: 2013-09-12 18:10 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-26 10:54:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alan Conway 2009-04-23 15:31:36 EDT
Description of problem:


The qpid-cluster errors are a little verbose and not really that useful – for example, when shutting down the cluster:

 

[root@lnaiqlv21 ~]# qpid-cluster -k

Warning: This command will shut down the entire cluster. Are you sure? [N]: y

Traceback (most recent call last):

  File "/usr/bin/qpid-cluster", line 316, in ?

    if e.__repr__().find("connection aborted") > 0:

AttributeError: Exception instance has no attribute '__repr__'

 

Wouldn’t it be good to produce a “connection closed” style message rather than a somewhat meaningless exception?

 

Also, running qpid-cluster with the cluster down:

 

[root@lnaiqlv21 ~]# qpid-cluster

Traceback (most recent call last):

  File "/usr/bin/qpid-cluster", line 316, in ?

    if e.__repr__().find("connection aborted") > 0:

AttributeError: error instance has no attribute '__repr__'

 

What about an error like ‘unable to connect to cluster’ instead?

 

I must confess to not being a fan of exposing java / python stack tracebacks to end-users, and would instead prefer Redhat replace these cases (and any other similar across other tools) with a useful set of errors, perhaps only exposing the full stack-trace if a debugging flag is used.
Comment 2 Nuno Santos 2010-05-26 10:54:38 EDT
Subset of BZ#498247

*** This bug has been marked as a duplicate of bug 498247 ***

Note You need to log in before you can comment on or make changes to this bug.