Bug 497451 - vif0.0 not set correctly when ifcfg-eth0 has MTU value
vif0.0 not set correctly when ifcfg-eth0 has MTU value
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xen (Show other bugs)
5.3
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Miroslav Rezanina
Virtualization Bugs
:
Depends On:
Blocks: 514498
  Show dependency treegraph
 
Reported: 2009-04-23 19:03 EDT by Matt Willsher
Modified: 2010-11-09 08:24 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-14 00:53:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt Willsher 2009-04-23 19:03:49 EDT
Description of problem:
When MTU value is defined in ifcfg-eth0 in Dom0 and xen kernel + associated startup scripts are used, the same MTU is propergated to peth0, xenbr0 and eth0 but not vif0.0. This leads to terrible network performance.
Setting MTU to the same value as the previously mentioned devices solves this issue.

Version-Release number of selected component (if applicable):
5.3

How reproducible:
Every time.

Steps to Reproduce:
1. Configure MTU=9000 in /etc/sysconfig/network-scripts/ifcfg-eth0 in Dom0
2. Reboot
3. Attempt large data transfer over, say, SMB
  
Actual results:
Dire network performance. Getting 2MB/s rather that 40MB/s.
As an aside, agitates issues with network under Vista, cause it to become unresponsive and require Disable/enable of network interface

Expected results:
Similar throughput to none Xen environment


Additional info:
Can be resolved by setting MTU manual on vif0.0
Testing has not yet been done for DomUs.
Comment 3 Miroslav Rezanina 2010-07-01 05:16:14 EDT
Retesting shows that MTU is not propagated to any other device than eth0 and performance is not degrading. 

What scripts do you use?? Can you give us xend-config.sxp for this case or retest it with rhel 5.5?
Comment 4 Matt Willsher 2010-07-01 10:47:09 EDT
I do not have the environment to test this further.
Comment 8 Miroslav Rezanina 2010-07-14 00:53:19 EDT
As we are not able to reproduce the problem and reproduce does not have the enviroment to test, we close this as WORKSFORME. If you ever encounter this problem, feel free to reopen the bz providing the setup of enviroment you reproduced the problem - ifcfg script file, ifconfig output.

Note You need to log in before you can comment on or make changes to this bug.