This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 497455 - hitting assert on resume
hitting assert on resume
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Kristian Høgsberg
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F11Blocker/F11FinalBlocker
  Show dependency treegraph
 
Reported: 2009-04-23 19:55 EDT by Matěj Cepl
Modified: 2009-04-25 06:01 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-25 06:01:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
/var/log/gdm/:0.log.1 (42.93 KB, text/plain)
2009-04-23 19:55 EDT, Matěj Cepl
no flags Details
/var/log/Xorg.0.log (48.81 KB, text/plain)
2009-04-23 19:57 EDT, Matěj Cepl
no flags Details
/var/log/dmesg (37.90 KB, text/plain)
2009-04-23 19:57 EDT, Matěj Cepl
no flags Details

  None (edit)
Description Matěj Cepl 2009-04-23 19:55:38 EDT
Created attachment 341038 [details]
/var/log/gdm/:0.log.1

Description of problem:
Every resume ends up in gdm login screen, which I guess means that X server crashes. Presented my logs to Dave Airlie and this is what I got:

<airlied> mcepl: oh it hits a nasty assert on resume
<airlied> you should file it with :0.log.1 attached.

so attaching that plus my beloved combo /var/log/Xorg.0.log and /var/log/dmesg (/etc/X11/xorg.conf contains just switching on Ctrl-Alt-Backspace).

Version-Release number of selected component (if applicable):
xorg-x11-drv-intel-2.7.0-1.fc11.x86_64

How reproducible:
100%

Steps to Reproduce:
1.suspend-to-ram
2.resume
3.
  
Actual results:
gdm login screen

Expected results:
wherever I was before

Additional info:
Comment 1 Matěj Cepl 2009-04-23 19:57:11 EDT
Created attachment 341039 [details]
/var/log/Xorg.0.log
Comment 2 Matěj Cepl 2009-04-23 19:57:30 EDT
Created attachment 341040 [details]
/var/log/dmesg
Comment 3 Matěj Cepl 2009-04-25 06:01:16 EDT
Seems to be fixed in xorg-x11-drv-intel-2.7.0-2.fc11.x86_64

Thanks.

Note You need to log in before you can comment on or make changes to this bug.