Bug 497460 - Suspend/resume works only once; does not resume second time
Suspend/resume works only once; does not resume second time
Status: CLOSED DUPLICATE of bug 497067
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-23 22:06 EDT by Saikat Guha
Modified: 2009-04-23 22:47 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-23 22:47:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/messages (89.71 KB, text/plain)
2009-04-23 22:06 EDT, Saikat Guha
no flags Details

  None (edit)
Description Saikat Guha 2009-04-23 22:06:33 EDT
Created attachment 341046 [details]
/var/log/messages

Description of problem:
Suspend/resume works only once. Suspending a second time manages to get to sleep state, but machine does not resume after that. Opening lid / pressing power button etc. does nothing. The LED light that normally blinks during the resume process doesn't blink. Machine needs to be hard rebooted.

See attached /var/log/messages:
Kernel BUG reported during the first suspend/resume cycle:
  BUG: sleeping function called from invalid context at kernel/workqueue.c:440
Also, on both attempts:
  kernel: [drm:i915_get_vblank_counter] *ERROR* trying to get vblank count for disabled pipe 0
Note, logs for second suspend/resume cycle don't hit the log since the machine doesn't resume.

Version-Release number of selected component (if applicable):
kernel-2.6.29.1-102.fc11.i586

How reproducible:
Always

Steps to Reproduce:
1. Suspend
2. Resume
3. Suspend
4. Resume
  
Actual results:
Machine will not resume. The LED light that normally blinks during the resume process doesn't blink.

Expected results:
Machine resumes.

Additional info:
  Hardware: 
    http://www.smolts.org/client/show/pub_8723ef2a-0781-4aa9-a49c-f20b18645cfc
Comment 1 Chuck Ebbert 2009-04-23 22:47:49 EDT

*** This bug has been marked as a duplicate of bug 497067 ***

Note You need to log in before you can comment on or make changes to this bug.