This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 497476 - Unhandled exception during installation, possibly LVM-related
Unhandled exception during installation, possibly LVM-related
Status: CLOSED DUPLICATE of bug 493699
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
anaconda_trace_hash:f8e8554afd65173cc...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-24 02:15 EDT by Thomas Borchsenius
Modified: 2009-04-24 11:11 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-24 11:11:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (27.51 KB, text/plain)
2009-04-24 02:15 EDT, Thomas Borchsenius
no flags Details

  None (edit)
Description Thomas Borchsenius 2009-04-24 02:15:04 EDT
The following was filed automatically by anaconda:
anaconda None exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/storage/devicelibs/lvm.py", line 411, in lvactivate
    raise LVMError("lvactivate failed for %s" % lv_name)
  File "/usr/lib/anaconda/storage/devices.py", line 1926, in setup
    lvm.lvactivate(self.vg.name, self._name)
  File "/usr/lib/anaconda/storage/devicetree.py", line 1371, in addUdevDevice
    lv_device.setup()
  File "/usr/lib/anaconda/storage/devicetree.py", line 1486, in populate
    self.addUdevDevice(dev)
  File "/usr/lib/anaconda/storage/__init__.py", line 265, in reset
    self.devicetree.populate()
  File "/usr/lib/anaconda/storage/__init__.py", line 90, in storageInitialize
    storage.reset()
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 128, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1317, in nextClicked
    self.anaconda.dispatch.gotoNext()
LVMError: lvactivate failed for lv_root
Comment 1 Thomas Borchsenius 2009-04-24 02:15:11 EDT
Created attachment 341102 [details]
Attached traceback automatically from anaconda.
Comment 2 Thomas Borchsenius 2009-04-24 02:19:58 EDT
First time running the installer, I let the installer create a partition schema with a password encryption for the root partition. When the installer tried to activated the new partitions, I got a similar failure to the above. The above trace is from a second try - however now it seems I never come to the stage where I can choose which disks to install to.
Comment 3 Thomas Borchsenius 2009-04-24 02:22:15 EDT
Don't know if it's important, but trying to inspect the partition layout in fdisk produced this message: "Partition 1 does not end on cylinder boundary."
Comment 4 Chris Lumens 2009-04-24 11:11:55 EDT

*** This bug has been marked as a duplicate of bug 493699 ***

Note You need to log in before you can comment on or make changes to this bug.