Bug 497521 - xorg screen resolution set to 1024X768 or lower
xorg screen resolution set to 1024X768 or lower
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nv (Show other bugs)
10
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Ben Skeggs
Fedora Extras Quality Assurance
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-24 08:55 EDT by Mike Reeves
Modified: 2009-12-18 04:19 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-18 04:19:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg startup log (49.18 KB, text/plain)
2009-04-24 08:55 EDT, Mike Reeves
no flags Details
startx -- -logverbose 6 - with driver "nv" in xorg.conf (34.38 KB, text/plain)
2009-04-25 06:33 EDT, Mike Reeves
no flags Details
For contrast: startx -- -logverbose 6 - with driver "vesa" in xorg.conf (39.78 KB, text/plain)
2009-04-25 06:58 EDT, Mike Reeves
no flags Details

  None (edit)
Description Mike Reeves 2009-04-24 08:55:53 EDT
Created attachment 341158 [details]
xorg startup log

Description of problem: Cannot get screen resolution beyond 1024X768 on Fedora 10. This was not a problem until some updates went on. I do not know which update killed the ability to go beyond 1024X768.

I have tried an ATI Radeon 4350 HD card as well as an nVidia GeForce 8400GS card with the same results. The monitor is a Westinhouse LCM-22w3 connected through a Belkin KVM Switch. I have tried connecting the monitor directly to the video card but the results are the same.

Note: I found that with the nVidia proprietary driver I can get beyond 1024X768 screen resolution but it requires that I rebuild the drive every time the kernel changes. I have since re-installed Feroda 10 and the nVidia proprietary drivers are no longer installed.

xorg.conf configurations, all product the same results 1024X768

1) no xorg.conf
2) monitor section only
3) device section using "nv"


Version-Release number of selected component (if applicable):
Kernel: 2.6.27.21-170.2.56.fc10.x86_64
Xorg: xorg-x11-server 1.5.3-15.fc10

How reproducible: Very 

Steps to Reproduce:
1. Reboot
  
Actual results:
Display: Unknown
Screen Resolution: 1024X768

Expected results:
Display: LCM-22w3
Screen Resolution: up to 1600X1050

Additional info: xorg.conf
Section "Monitor"
    Identifier     "Monitor0"
    ModelName      "Westinghouse LCM-22w3"
    HorizSync       30.0 - 82.0
    VertRefresh     56.0 - 76.0
    DisplaySize	    1600 1050
EndSection

Section "Device"
    Identifier     "nVidiaGeForce0"
    Driver         "nv"
    Option         "AccelMethod" "EXA" <- tried with and without
    Option         "FlatPanel" "On"    <- tried with and without
EndSection

Section "Screen"
    Identifier     "Default Screen"
    Device         "nVidiaGeForce0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Modes      "1680x1050" "1400x900" "1280x1024" "1280x960" "1280x800" 
"1152x864" "1024x768" "800x600" "640x480"
    EndSubSection
EndSection
Comment 1 Mike Reeves 2009-04-24 16:52:12 EDT
using the following in xorg.conf I was able to get to 1280X1024 but would like to get to 1440X900 or 1440X1050
Section "Device"
    Identifier     "nVidiaGeForce0"
    Driver         "vesa"
endSection

Also changes Modes in SubSection to
    SubSection     "Display"
        Modes      "1680x1050" "1440x900" "1280x1024" "1280x960" "1280x800" 
"1152x864" "1024x768" "800x600" "640x480"
    EndSubSection
Comment 2 Mike Reeves 2009-04-24 18:18:00 EDT
Change xorg.conf to -
Section "Monitor"
    Identifier     "Monitor0"
    ModelName      "Westinghouse LCM-22w3"
    HorizSync       30.0 - 82.0
    VertRefresh     60
    DisplaySize     1680 1050
EndSection

got me to -

[swampfox@swamplnx ~]$ xrandr
Screen 0: minimum 640 x 480, current 1600 x 1200, maximum 1600 x 1200
default connected 1600x1200+0+0 0mm x 0mm
   1600x1200      61.0* 
   1280x1024      61.0  
   1024x768       61.0  
   800x600        61.0  
   640x480        60.0  

But I'd still like to get to 1440X900 or 1050. There should be lots of resolution settings between 1024X768 and 1600X1200.
Comment 3 Ben Skeggs 2009-04-24 22:05:06 EDT
Can you post /var/log/Xorg.0.log from the NVIDIA binary driver, preferably with X started with "startx -- -logverbose 6".

Thanks!
Comment 4 Mike Reeves 2009-04-25 06:33:26 EDT
Created attachment 341309 [details]
startx -- -logverbose 6 - with driver "nv" in xorg.conf

Please note that the vesa driver only has a limited number of modes as well.
Comment 5 Mike Reeves 2009-04-25 06:58:08 EDT
Created attachment 341310 [details]
For contrast: startx -- -logverbose 6 - with driver "vesa" in xorg.conf

Just to add some addition information that may be helpful I ran the startx -- -logverbose 6 with the vesa driver because it comes up with 1280X1024 and 1600X1200. I'd like to be able to set it to 1440X900 as I do on my windows machines. Both Windows XP and Windows 7 Beta are attached to the same KVM switch and have a resultion of 1440X900 using the same Westinhouse LCM-22w3 monitor.
Comment 6 Mike Reeves 2009-07-29 11:07:23 EDT
Hello - has anyone looked at this issue. I put on the new release of fedora 11 and still have the same problem.The nvidia driver only gets to 1024X768 and the vesa driver only gets to 1280X1024.

It appears the EDID is not picking up my monitor correctly. The monitor is a Westinghouse LCM-22w3.
Comment 7 Bug Zapper 2009-11-18 06:50:48 EST
This message is a reminder that Fedora 10 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 10.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '10'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 10's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 10 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 Bug Zapper 2009-12-18 04:19:50 EST
Fedora 10 changed to end-of-life (EOL) status on 2009-12-17. Fedora 10 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.