Bug 497536 - numpy-f2py subpackage broken -- numpy doesn't work without it.
numpy-f2py subpackage broken -- numpy doesn't work without it.
Status: CLOSED DUPLICATE of bug 496277
Product: Fedora
Classification: Fedora
Component: numpy (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Gwyn Ciesla
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-24 10:22 EDT by Matthew Miller
Modified: 2009-04-24 10:53 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-24 10:53:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Miller 2009-04-24 10:22:57 EDT
Description of problem:

numpy package 1.3.0-2.fc11 splits out numpy-f2py into separate package. But without numpy-f2py installed, "import numpy" tracebacks.

Version-Release number of selected component (if applicable):

1.3.0-2.fc11

How reproducible:

Every time.

Steps to Reproduce:
1. Install numpy package.
2. Do not install numpy-f2py subpackage.
3. python -c 'import numpy'
  
Actual results:

Traceback (most recent call last):
  File "../../vecgen-last2svg-1.40-bw.py", line 3, in <module>
    import numpy
  File "/usr/lib64/python2.6/site-packages/numpy/__init__.py", line 130, in <module>
    import add_newdocs
  File "/usr/lib64/python2.6/site-packages/numpy/add_newdocs.py", line 9, in <module>
    from lib import add_newdoc
  File "/usr/lib64/python2.6/site-packages/numpy/lib/__init__.py", line 13, in <module>
    from polynomial import *
  File "/usr/lib64/python2.6/site-packages/numpy/lib/polynomial.py", line 18, in <module>
    from numpy.linalg import eigvals, lstsq
ImportError: No module named linalg



Expected results:

Successful import of module.
Comment 1 Matthew Miller 2009-04-24 10:24:26 EDT
adding pbrobinson to cc list, since he's referenced in the changelog as the originator of this change.
Comment 2 Gwyn Ciesla 2009-04-24 10:29:19 EDT
This is fixed in -4, which is in rawhide and should be tagged for dist-f11.  Can you confirm?
Comment 3 Peter Robinson 2009-04-24 10:39:51 EDT
This is a dupe of 496277 and the fix is in rawhide today with the announcement just going out to the mailing list.
Comment 4 Matthew Miller 2009-04-24 10:53:58 EDT
okay, thanks. hasn't hit the mirrors yet but i trust it will soon.

*** This bug has been marked as a duplicate of bug 496277 ***

Note You need to log in before you can comment on or make changes to this bug.