Bug 497544 - servicing a catch-up request causes clustered broker to crash if replication exchange is defined
servicing a catch-up request causes clustered broker to crash if replication...
Status: CLOSED ERRATA
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-cpp (Show other bugs)
1.1.1
All Linux
urgent Severity medium
: 1.1.2
: ---
Assigned To: Gordon Sim
Martin Kudlej
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-24 11:30 EDT by Gordon Sim
Modified: 2009-06-12 13:39 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-12 13:39:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch (1.03 KB, patch)
2009-05-11 15:59 EDT, Gordon Sim
no flags Details | Diff

  None (edit)
Description Gordon Sim 2009-04-24 11:30:44 EDT
Description of problem:

If a replication exchange is defined on a clustered broker, when a new node joins the cluster the node that tries to send it the necessary cluster state crashes.

Version-Release number of selected component (if applicable):

qpidd-0.5.752581-5.el5

How reproducible:

100%

Steps to Reproduce:
1. start clustered node with replication exchange plugin loaded
2. create a replication exchange using qpid-config
3. start a new node for the cluster
  
Actual results:

first node crashes

Expected results:

first node doesn't crash(!)

Additional info:

This is caused by a bug whereby the size of the encoded representation of the exchange state is changed during encode and consequently it overruns the buffer.

There is a workaround which is to ensure that when declaring the replication exchange you specify "qpid.replication-event.sequence"=0 in the arguments to the exchange. E.g. see attached patch which is used for step 2 works around the issue.
Comment 1 Gordon Sim 2009-05-11 15:59:24 EDT
Created attachment 343498 [details]
patch

Fixed on trunk as r773667, attached patch for r752581.
Comment 2 Gordon Sim 2009-05-28 06:14:41 EDT
Fixed in qpidd-0.5.752581-8.el5
Comment 3 Martin Kudlej 2009-05-29 08:01:43 EDT
Tested on RHEL5.3 x86_64/i386 qpidd-0.5.752581-9.el5 and it works so --> VERIFIED.
Comment 5 errata-xmlrpc 2009-06-12 13:39:04 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1097.html

Note You need to log in before you can comment on or make changes to this bug.