Bug 497546 - iSCSI autopart puts '/boot' on iSCSI volume
iSCSI autopart puts '/boot' on iSCSI volume
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-24 11:40 EDT by James Laska
Modified: 2013-09-02 02:35 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-24 15:38:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot (120.98 KB, image/png)
2009-04-24 11:40 EDT, James Laska
no flags Details
anaconda-logs.tgz (/tmp/*log) (27.95 KB, application/octet-stream)
2009-04-24 11:41 EDT, James Laska
no flags Details

  None (edit)
Description James Laska 2009-04-24 11:40:39 EDT
Created attachment 341195 [details]
Screenshot

Description of problem:

On a system without iBFT support, autopart with iSCSI places the '/boot' partition on the remote iSCSI volume.  This results in an unbootable setup.

Version-Release number of selected component (if applicable):
anaconda-11.5.0.47

How reproducible:


Steps to Reproduce:
1. Select "Use Entire drive"
2. Add a remote iSCSI volume
3. Check [X] review partitioning
  
Actual results:

See attached screenshot and log files.

Expected results:

Unless iBFT is supported, any boot partitions should be on local storage volumes.

Additional info:

 * See attached files
Comment 1 James Laska 2009-04-24 11:41:55 EDT
Created attachment 341197 [details]
anaconda-logs.tgz (/tmp/*log)
Comment 2 Hans de Goede 2009-04-24 15:38:50 EDT
James,

I appreciate your testing efforts, and I can understand you seeing this
as a bug, but it is not a bug, atleast not really. You pressed the advanced
storage button to get into this state, once you do that all bets are of :)

More seriously, if you start looking at exotic storage setups there are to many ways people can shoot themselves in the foot, if we have to check them all we will fight a loosing battle.

So I'm closing this as won't fix.

Note You need to log in before you can comment on or make changes to this bug.