Bug 497552 - SIGILL in pixman on Pentium I on xserver startup and vesa driver
Summary: SIGILL in pixman on Pentium I on xserver startup and vesa driver
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: pixman
Version: 10
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Adam Jackson
QA Contact: Fedora Extras Quality Assurance
URL: http://bugs.freedesktop.org/show_bug....
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-04-24 16:40 UTC by Alex Villacís Lasso
Modified: 2009-05-02 16:35 UTC (History)
1 user (show)

Fixed In Version: 0.12.0-3.fc10
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-05-02 16:35:56 UTC


Attachments (Terms of Use)
Xorg.0.log after X server crashes (22.62 KB, text/plain)
2009-04-24 16:40 UTC, Alex Villacís Lasso
no flags Details
Output of lspci -v (5.23 KB, text/plain)
2009-04-24 16:45 UTC, Alex Villacís Lasso
no flags Details
Contents of /proc/cpuinfo (358 bytes, text/plain)
2009-04-24 16:47 UTC, Alex Villacís Lasso
no flags Details
Contents of /proc/meminfo (924 bytes, text/plain)
2009-04-24 16:47 UTC, Alex Villacís Lasso
no flags Details

Description Alex Villacís Lasso 2009-04-24 16:40:19 UTC
Created attachment 341211 [details]
Xorg.0.log after X server crashes

Description of problem:

On a fairly old machine (Pentium 1, 200 Mhz, 192 Mb RAM, i430tx mainboard) I installed Fedora 10, because my main computer is damaged. On startx, the X server crashes inside pixman (backtrace attached). Signal thrown is 4 (SIGILL). Updating to latest xorg-x11-server-Xorg and xorg-x11-drv-vesa does not solve the issue.

On the main computer (Pentium 4), the same configuration works OK.

Version-Release number of selected component (if applicable):
pixman-0.12.0-2.fc10.i386
xorg-x11-server-Xorg-1.5.3-15.fc10.i386
xorg-x11-drv-vesa-2.2.0-3.fc10.i386

How reproducible:

Always

Steps to Reproduce:
1. Get system with Pentium 1 processor
2. Configure xserver with vesa driver
3. Attempt to start xserver by any method.
  
Actual results:

The X server starts up, switches to graphics mode, shows the usual B/W pattern, but then shuts down with the attached backtrace.

Expected results:

The X server should run normally and end up showing graphical desktop.

Additional info:

I have a copy of freedesktop.org pixman git tree so I am in a position to test updates on demand.

I have seen other pixman bug reports here, and this one looks a bit like bugs #451831 and #472000 , except that mine happens right on xserver startup. Not even plain xinit with xterm works.

Comment 1 Alex Villacís Lasso 2009-04-24 16:45:54 UTC
Created attachment 341213 [details]
Output of lspci -v

This is the PCI configuration for this machine. Video card is an old OAK SpitFire OTI64111 that is not supported in current xorg except through the vesa driver.

Comment 2 Alex Villacís Lasso 2009-04-24 16:47:02 UTC
Created attachment 341215 [details]
Contents of /proc/cpuinfo

Just to prove this is an actual Pentium I.

Comment 3 Alex Villacís Lasso 2009-04-24 16:47:36 UTC
Created attachment 341216 [details]
Contents of /proc/meminfo

Comment 4 Alex Villacís Lasso 2009-04-27 16:48:03 UTC
This bug is already fixed in a later version of pixman, by git commit 1c5de7b05831b3d66821707276b71974a232f5c7 . The corresponding freedesktop report is http://bugs.freedesktop.org/show_bug.cgi?id=17729 and marks it as already fixed. I found this after creating a patch that is equivalent to 1c5de7b05831b3d66821707276b71974a232f5c7 and checking whether current HEAD for pixman still contains the bug.

Please update pixman RPM to a later version.

Comment 5 Fedora Update System 2009-04-28 21:15:59 UTC
pixman-0.12.0-3.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/pixman-0.12.0-3.fc10

Comment 6 Fedora Update System 2009-05-02 16:35:52 UTC
pixman-0.12.0-3.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.