Bug 497565 - php-pear-Auth_SASL shouldn't require php
Summary: php-pear-Auth_SASL shouldn't require php
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: php-pear-Auth-SASL
Version: 10
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Remi Collet
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-04-24 18:36 UTC by Martí­n Marqués
Modified: 2009-05-09 04:20 UTC (History)
1 user (show)

Fixed In Version: 1.0.2-6.fc10
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-05-09 03:56:27 UTC


Attachments (Terms of Use)

Description Martí­n Marqués 2009-04-24 18:36:42 UTC
Description of problem:

Dependency problems. php-pear-Auth_SASL requires php, which requires an httpd server.

I should only require php-pear.

AFAIR in FC7 PHP was split in 2. One part for the mod_php apache module and the php-cli with the executable version.

Version-Release number of selected component (if applicable):

php-pear-Auth-SASL.noarch 1.0.2-4.fc6

How reproducible:

# yum deplist php-pear-Auth-SASL
Loaded plugins: downloadonly, fastestmirror, priorities, refresh-packagekit, security
Loading mirror speeds from cached hostfile
 * rpmfusion-nonfree-updates: mirrors.cat.pdx.edu
 * fedora: www.las.ic.unicamp.br
 * rpmfusion-free-updates: mirrors.cat.pdx.edu
 * rpmfusion-free: mirrors.cat.pdx.edu
 * updates: ftp.wsisiz.edu.pl
 * rpmfusion-nonfree: mirrors.cat.pdx.edu
4 packages excluded due to repository priority protections
Finding dependencies:
package: php-pear-Auth-SASL.noarch 1.0.2-4.fc6
  dependency: /bin/sh
   provider: bash.x86_64 3.2-29.fc10
   provider: bash.x86_64 3.2-30.fc10
  dependency: php-pear(PEAR) >= 1.4.9
   provider: php-pear.noarch 1:1.7.2-2.fc10
  dependency: /usr/bin/pear
   provider: php-pear.noarch 1:1.7.2-2.fc10
  dependency: php >= 4.0.0
   provider: php.x86_64 5.2.6-5

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Remi Collet 2009-04-25 05:41:44 UTC
You're right pear package shouldn't require php (and we have updated the Guidelines for this)

Version check could be done against php-common.

I will fix this minor issue.

Comment 2 Fedora Update System 2009-04-25 06:11:48 UTC
php-pear-Auth-SASL-1.0.2-6.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/php-pear-Auth-SASL-1.0.2-6.fc11

Comment 3 Fedora Update System 2009-04-25 06:12:37 UTC
php-pear-Auth-SASL-1.0.2-6.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/php-pear-Auth-SASL-1.0.2-6.fc10

Comment 4 Fedora Update System 2009-04-27 21:27:01 UTC
php-pear-Auth-SASL-1.0.2-6.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update php-pear-Auth-SASL'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-3966

Comment 5 Fedora Update System 2009-05-09 03:56:23 UTC
php-pear-Auth-SASL-1.0.2-6.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 6 Fedora Update System 2009-05-09 04:20:56 UTC
php-pear-Auth-SASL-1.0.2-6.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.