Bug 497589 - Qt 4.5.1-3 not backportable to RHEL 4 and 5
Qt 4.5.1-3 not backportable to RHEL 4 and 5
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: qt (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
http://koji.fedoraproject.org/koji/bu...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-24 17:21 EDT by Tuan Hoang
Modified: 2010-04-22 18:09 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-24 20:04:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Patch adds fixes and missing conditionals for Phonon, GtkStyle and gtk-update-icon-cache. (2.99 KB, patch)
2009-04-24 17:21 EDT, Tuan Hoang
no flags Details | Diff

  None (edit)
Description Tuan Hoang 2009-04-24 17:21:27 EDT
Created attachment 341251 [details]
Patch adds fixes and missing conditionals for Phonon, GtkStyle and gtk-update-icon-cache.

Description of problem:
Rawhide qt.spec is not compatible when EPEL (or individual users like me) backport to RHEL 4 or 5.

Version-Release number of selected component (if applicable):
Version	4.5.1-3

How reproducible:
Every time

Steps to Reproduce:
RHEL4:  rpmbuild -ba --clean --define "dist .rhel4" --define "rhel 4" qt.spec
RHEL5:  rpmbuild -ba --clean --define "dist .rhel5" --define "rhel 5" qt.spec
  
Actual results:
RHEL4:  Build fails because of missing Phonon, GtkStyle, gtk-update-icon-cache
RHEL5:  Build fails because of missing Phonon.

Expected results:
RHEL4:  Build backported packages without Phonon and GtkStyle support.
RHEL5:  Build backported packages with Phonon and Phonon-backend.

Additional info:
Attached is a patch against the current Rawhide build 4.5.1-3 that adds fixes and missing conditionals for Phonon, GtkStyle and gtk-update-icon-cache.
Comment 1 Kevin Kofler 2009-04-24 18:20:41 EDT
qt4 cannot go into EPEL 5 because it is part of RHEL 5, nor into EPEL 4 because that'd break upgrade paths to RHEL 5.

For missing Phonon, why not just backport the standalone phonon package as well? In particular, with Qt's copy of Phonon, you don't get the xine-lib backend which is the recommended default. At most, your change is useful for bootstrapping.

This change:
> -gtk-update-icon-cache -q %{_datadir}/icons/hicolor 2> /dev/null ||:
> +[ -x /usr/bin/gtk-update-icon-cache ] && gtk-update-icon-cache -q %{_datadir}/icons/hicolor 2> /dev/null ||:
makes no sense, the 2> /dev/null ||: is there also to treat the case where the executable is missing, your [ -x /usr/bin/gtk-update-icon-cache ] && is redundant.

The only change which could possibly make sense is the QGtkStyle change. But can't you build it against evolution28-gtk2 or otherwise backport a newer GTK+?
Comment 2 Kevin Kofler 2009-04-24 18:27:25 EDT
To be clear: There's no Qt 4.5 or even 4.4 in EL5, you get an ancient Qt 4.2.1. But because of this ancient version being offered, a newer version cannot be imported into EL5 nor EL4, except possibly with a qt45 hack similar to the evolution28-* packages.

I checked the versions: evolution28-gtk2 in EL4 is exactly the same version as the gtk2 in EL5, so if QGtkStyle builds on EL5, you should be able to get it to build against evolution28-gtk2 in EL4. You may have to patch some search paths. (It won't be the only non-Evolution app using the libs, they're also used by the current firefox in EL4.)
Comment 3 Kevin Kofler 2009-04-24 20:04:29 EDT
And one more thing: specfiles are not required to be buildable on anything other than the Fedora release the branch is for. In KDE SIG, we choose to support multiple releases with the same specfile for most of our packages to ease maintenance. But there is nothing which says that a specfile in Fedora has to be buildable on any EL release. So I'm afraid I'll have to close this as NOTABUG.
Comment 4 Tuan Hoang 2009-04-25 11:45:11 EDT
Thanks for the tips and corrections.  I will check out evolution28-gtk2 and see if I can build against that.

I realize that Fedora has no guarantees for cross-building under any RHEL, but could you at least consider my fixes to the configure script (patch lines 386-397) and also the proper 'phonon_backend' wrappers?

It would just make my life a little easier since I'm trying to maintain a suite of my company's applications (require Qt 4.4+) across RHEL 4, 5, and Fedora 10.
Comment 5 Rex Dieter 2009-04-25 13:30:30 EDT
Nod, it has always been at least my intention to make a best effort that our qt4 packages buildable on rhel 5 (4 is harder, but we can always try).  I'll take a look into this shortly, and make adjustments where possible.
Comment 6 yan bellavance 2010-04-22 18:09:55 EDT
hum, I have rhel 5 with qt4.6 running just fine.  The only thing I needed to do is provide my own fontconfig lib because the one provided by rhel has a bug and needs to be updated by 1 sub-sub-version number

Note You need to log in before you can comment on or make changes to this bug.