Bug 497595 - firefox crashes at or soon after startup
firefox crashes at or soon after startup
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
9
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-24 18:01 EDT by Michael Ploujnikov
Modified: 2009-04-28 06:43 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-28 06:43:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
backtrace (12.33 KB, text/plain)
2009-04-24 18:01 EDT, Michael Ploujnikov
no flags Details
firefox -g backtrace after segfault (15.04 KB, text/plain)
2009-04-26 15:52 EDT, Michael Ploujnikov
no flags Details
firefox -g backtrace after segfault (fixed) (18.17 KB, text/plain)
2009-04-26 16:00 EDT, Michael Ploujnikov
no flags Details
another backtrace (17.37 KB, text/plain)
2009-04-26 22:29 EDT, Michael Ploujnikov
no flags Details

  None (edit)
Description Michael Ploujnikov 2009-04-24 18:01:11 EDT
Created attachment 341256 [details]
backtrace

Description of problem:
When I start firefox for the first time (or sometimes a couple of times) after a reboot it encounters a segmentation fault. The crash can happen as early as before all of the (about) 10 saved tabs (different content from day to day) load and as late as a few minutes into the browsing.

Version-Release number of selected component (if applicable):
firefox-3.0.8-1.fc9.x86_64

How reproducible:
Not always, but often enough to be annoying.

Steps to Reproduce:
1. type 'firefox' in a terminal emulator.
2. start using firefox until it crashes
  
Actual results:
Firefox crashes with a Segmentation Fault

Expected results:
No crashing/segfaults.

Additional info:
Usually, starting firefox for the second time (after a reboot) does not result in a crash (and I have it on for hours). Sometimes it crashes more than once, but not constantly and probably less than 10 times. Basically it seems that if it has been running for about 20 minutes then it probably won't crash.

As per instructions in bug #491765 I'm attaching the backtrace.
Comment 1 Matěj Cepl 2009-04-26 03:59:16 EDT
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

First of all, could we get output of the command

	rpm -qa *xulrun* *firefox* *mozilla* *flash* *plugin*

Please also install firefox-debuginfo (debuginfo-install is from
yum-utils package).

	debuginfo-install firefox

You will have to run firefox with a parameter -g for some time. That will start firefox running inside of gdb debugger. Then use command run and wait until firefox crashes. When it happens, you should go back to the gdb and run

	(gdb) thread apply all backtrace

This produces usually many screens of the text. Copy all of them into a text editor and attach the file to the bug as an uncompressed attachment.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Michael Ploujnikov 2009-04-26 15:52:03 EDT
Created attachment 341368 [details]
firefox -g backtrace after segfault
Comment 3 Michael Ploujnikov 2009-04-26 15:53:03 EDT
$ rpm -qa *xulrun* *firefox* *mozilla* *flash* *plugin*
audacious-plugins-1.4.5-1.fc9.x86_64
java-1.6.0-openjdk-plugin-1.6.0.0-0.25.b09.fc9.x86_64
setroubleshoot-plugins-2.0.11-1.fc9.noarch
mozilla-filesystem-1.9-2.fc9.x86_64
gstreamer-plugins-pulse-0.9.5-0.5.svn20070924.fc9.x86_64
gstreamer-plugins-bad-0.10.7-4.fc9.x86_64
gstreamer-plugins-ugly-0.10.8-2.fc9.x86_64
totem-mozplugin-2.23.2-13.fc9.x86_64
gstreamer-plugins-good-0.10.8-10.fc9.x86_64
flash-plugin-10.0.22.87-release.i386
gstreamer-plugins-base-0.10.19-4.fc9.x86_64
nspluginwrapper-debuginfo-1.3.0-2.fc9.x86_64
nspluginwrapper-1.3.0-2.fc9.i386
xulrunner-1.9.0.8-1.fc9.x86_64
libflashsupport-000-0.5.svn20070904.i386
PackageKit-yum-plugin-0.3.12-1.fc9.x86_64
alsa-plugins-pulseaudio-1.0.16-4.fc9.x86_64
xulrunner-debuginfo-1.9.0.8-1.fc9.x86_64
gstreamer-plugins-flumpegdemux-0.10.15-2.fc9.x86_64
nspluginwrapper-1.3.0-2.fc9.x86_64

I've already installed everything with 'debuginfo-install firefox' prior to submitting this bug.
Comment 4 Michael Ploujnikov 2009-04-26 16:00:35 EDT
Created attachment 341369 [details]
firefox -g backtrace after segfault (fixed)

The previous attachment was corrupted due to poor copy-pasting.
Comment 5 Michael Ploujnikov 2009-04-26 22:29:58 EDT
Created attachment 341376 [details]
another backtrace

This is another (seemingly) different backtrace of firefox crashing at startup on my system.
Comment 6 Matěj Cepl 2009-04-27 12:50:38 EDT
Hmm, cannot reporduce here. Does it happen also when you start firefox in safe-mode? (e.g., run firefox -safe-mode in gnome-terminal)
Comment 7 Michael Ploujnikov 2009-04-27 19:41:12 EDT
I tried two times (two reboots) and I wasn't able to reproduce this by running 'firefox -safe-mode'.
Comment 8 Matěj Cepl 2009-04-28 06:43:17 EDT
(In reply to comment #7)
> I tried two times (two reboots) and I wasn't able to reproduce this by running
> 'firefox -safe-mode'.  

OK, then I have to blame some of your extensions/plugins then.

Closing as NOTABUG (that is, not OUR bug).

Note You need to log in before you can comment on or make changes to this bug.