Bug 497600 - UI review: abrt-gui shows the wrong things
UI review: abrt-gui shows the wrong things
Status: CLOSED DUPLICATE of bug 489624
Product: Fedora
Classification: Fedora
Component: abrt (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Jiri Moskovcak
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-24 18:26 EDT by Matthias Clasen
Modified: 2015-02-01 17:48 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-06 11:24:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthias Clasen 2009-04-24 18:26:01 EDT
abrt-gui devotes half of its window to showing a generic description of the application that has crashed, but there seems to be no way to learn details about the crash itself. This seems backwards. If I open this ui, it is because I want to learn more about the crash that happened, not read some generic text about the metacity window manager. Allowing the user to review the data that will be sent off when he hits the 'Report' button is very important, since he may ne concerned about private data being included in the report. Also, being able to see the stacktrace is important to make this tool useful for developers who may want to see details of the crash happening on their own machine.
Comment 1 Bug Zapper 2009-06-09 10:31:56 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Michal Nowak 2009-06-09 17:59:42 EDT
I agree here with Matthias. But frankly abrt needs a lot of GUI clean up work.
Comment 3 Matthias Clasen 2009-07-17 12:47:09 EDT
I have now managed to see the window with the bug report details that you get after clicking the report button. 

It does technically show the things that it is going to send off, and allows you to exclude the stack trace, but it really really needs a lot of clean up work.

- A treeview is entirely the wrong ui for showing this. It would be much better to show the generated report in a text view, and let the user edit it. If you want to keep the 'exclude stacktrace' functionality, you can insert some markers that let you easily cut out the stacktrace when the user unchecks some checkbox.

- The window title must not be "CCMainWindow.py"

- The button should not be "Apply", but rather "Send" or something like that

- The button order is wrong
Comment 4 Jiri Moskovcak 2009-07-20 11:56:02 EDT
Changed the window title to "Report"
Changed the button label to "Send"
Fixed the button order.

The request for GUI design has been sent, we're waiting for the mock-ups and artwork, but any ideas are still welcome.

Jirka
Comment 5 Denys Vlasenko 2009-10-06 11:24:18 EDT

*** This bug has been marked as a duplicate of bug 489624 ***

Note You need to log in before you can comment on or make changes to this bug.