Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 497625 - Add vmchannel support to qemu-kvm
Add vmchannel support to qemu-kvm
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kvm (Show other bugs)
5.5
All Linux
low Severity medium
: rc
: ---
Assigned To: Eduardo Habkost
: Reopened
Depends On:
Blocks: 512696
  Show dependency treegraph
 
Reported: 2009-04-25 05:08 EDT by Richard W.M. Jones
Modified: 2013-01-09 16:35 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-28 04:41:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
kvm-specify-vmchannel-as-a-net-option.patch (3.01 KB, patch)
2009-07-17 07:00 EDT, Richard W.M. Jones
no flags Details | Diff

  None (edit)
Description Richard W.M. Jones 2009-04-25 05:08:30 EDT
Upstream qemu and KVM contain a very small patch which adds vmchannel
(-net channel) support:

http://lists.gnu.org/archive/html/qemu-devel/2009-02/msg01042.html

This bug is to track whether we can add this patch for RHEL 5.4.

I know this is a bit late in the day ...
Comment 1 Richard W.M. Jones 2009-05-19 12:01:38 EDT
I took a good look at the code, and the patch is
non-trivial to apply.  We will look instead at
whether we can get the required support into
EPEL's qemu.

Pushing this out until at least 5.5, and perhaps
dropping it entirely.
Comment 2 Richard W.M. Jones 2009-06-05 04:07:29 EDT
An updated qemu has been pushed to EPEL, which
reduces the need for this in RHEL.  Closing the bug.
Comment 3 Richard W.M. Jones 2009-07-17 07:00:22 EDT
Created attachment 354132 [details]
kvm-specify-vmchannel-as-a-net-option.patch

Reopening this bug for consideration for inclusion
in 5.5 (or 5.4 if there is time).  I have an updated
and tested patch which applies cleanly to our current
KVM package in RHEL 5.4 Beta.
Comment 7 Richard W.M. Jones 2009-09-21 14:15:09 EDT
Everyone keeps asking me about this, so:

We just posted a patch to upstream libguestfs which
removes the use of vmchannel entirely **although it
still requires SLIRP (user mode networking)** in qemu/kvm:

https://www.redhat.com/archives/libguestfs/2009-September/msg00113.html

*Assuming* that no major problems are found in this
(which is still not reviewed upstream), then it
would make this BZ obsolete.

However as noted above, we still need SLIRP in qemu.
Comment 8 Richard W.M. Jones 2009-09-28 04:41:14 EDT
Patch to libguestfs went in, seems to be working.

I'm going to close this bug for now as a result.

Note You need to log in before you can comment on or make changes to this bug.