Bug 497654 - Couldn't allocate framebuffer error on a Nvidia Vanta since version 0.0.12-29
Couldn't allocate framebuffer error on a Nvidia Vanta since version 0.0.12-29
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nouveau (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Ben Skeggs
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-25 15:34 EDT by Ivo Anjo
Modified: 2009-05-04 04:49 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-04 04:49:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log (25.85 KB, text/plain)
2009-04-25 15:34 EDT, Ivo Anjo
no flags Details

  None (edit)
Description Ivo Anjo 2009-04-25 15:34:49 EDT
Created attachment 341324 [details]
Xorg.0.log

Description of problem:
The last working version of nouveau for the vanta was nouveau-0.0.12-27.20090413git7100c06.fc11.i586.rpm . Since xorg-x11-drv-nouveau-0.0.12-29.20090417gitfa2f111.fc11.i586.rpm X doesn't start and it gives a fatal error "Couldn't allocate framebuffer" (same thing happens with 0.0.12-30).

Version-Release number of selected component (if applicable):
0.0.12-29.20090417gitfa2f111

How reproducible:
Always
Comment 1 Ivo Anjo 2009-05-03 08:10:06 EDT
I've been retesting with nouveau-0.0.12-32.20090501gitf69b34a.fc11.i586 and it seems this is related to nouveau now not being always able to setup 1280x1024.

This error occured to me on a tft monitor with native 1280x1024 resolution.

Now I've been testing with two crts (also capable of 1280x1024), a Compaq FS740 and a NEC FE700.

If I boot the computer with the compaq monitor attached, nouveau chooses 1152x864 75.0, and the xrandr output is:
Screen 0: minimum 320 x 200, current 1152 x 864, maximum 2032 x 2048
VGA-0 connected 1152x864+0+0 (normal left inverted right x axis y axis) 330mm x 250mm
   1280x1024      60.0  
   1152x864       75.0* 
   1024x768       85.0     75.0     60.0  
   800x600        85.1     75.0     60.3  
   640x480        85.0     59.9  
   720x400        70.1
But trying to set 1280x1024 I get this error:
xrandr --output VGA-0 --mode 1280x1024
X Error of failed request:  BadMatch (invalid parameter attributes)
  Major opcode of failed request:  149 (RANDR)
  Minor opcode of failed request:  7 ()
  Serial number of failed request:  19
  Current serial number in output stream:  20

If I boot the computer with no monitor attached, or with the NEC monitor, I can set 1280x1024, even if I later switch to the compaq monitor.

So I'm guessing there's some problem in setting 1280x1024 in some cases, and since the tft native resolution is 1280x1024, nouveau tries to set that resolution on X start and fails. Since for the crt it chooses something smaller by default, only "part" of the problem manifests itself.
Comment 2 Ivo Anjo 2009-05-03 08:17:38 EDT
I forgot to add that with release -27, I can boot with the compaq monitor and set 1280x1024 just fine.
Comment 3 Ben Skeggs 2009-05-04 04:49:13 EDT
Fixed in xorg-x11-drv-nouveau-0.0.12-33.20090501gitf69b34a.fc11.

Thanks!

Note You need to log in before you can comment on or make changes to this bug.