Bug 497659 - rssnow applet blank with qt-4.5.1
rssnow applet blank with qt-4.5.1
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kdeplasma-addons (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks: Qt451
  Show dependency treegraph
 
Reported: 2009-04-25 16:48 EDT by Rex Dieter
Modified: 2009-06-15 21:35 EDT (History)
7 users (show)

See Also:
Fixed In Version: 4.2.3-3.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-15 21:35:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 190651 None None None Never

  None (edit)
Description Rex Dieter 2009-04-25 16:48:13 EDT
summary says it all.
Comment 1 Sven Lankes 2009-05-13 15:42:50 EDT
From

http://bugs.archlinux.org/task/14447

I have found a KDE-based work around that fixes the bug in the plasmoid code. See the KDE bug report above for more details but if you want to maintain the bugfix, it is a one-liner in kdeplasma-addons-4.2.3/applets/rssnow/scroller.cpp:
comment out scroller.cpp line 65:
//setFlag(QGraphicsItem::ItemClipsChildrenToShape, true);
This flag causes the bug, and the work-around's only negaitive effect is that the scrolling stories will not be clipped outside the plasmoid's window while animating. That is a little ugly, but at least operational until Qt is fixed.

As noone upstream seems to be working on patching this issue for 4.2.x, we might want to add the patch.
Comment 2 Rex Dieter 2009-05-18 15:46:31 EDT
I'll snag this.
Comment 3 Rex Dieter 2009-05-18 15:59:18 EDT
Oh gosh, with the patch, it's pretty darn unusable still.  I'll post a screenshot.
Comment 4 Rex Dieter 2009-05-18 16:00:29 EDT
bleh, on logout/login not nearly as bad. ok, people will complain, but it's at least better than before alright.
Comment 5 Rex Dieter 2009-05-18 16:15:00 EDT
Patch included in kdeplasma-addons-4.2.3-2, which should be done separately from the kde-4.2.3 update (include with qt-4.5.1 or do by itself).
Comment 6 Jaroslav Reznik 2009-05-19 06:34:56 EDT
Hmm, it's better but still looks strange as it's missing clipping...
Comment 7 Fedora Update System 2009-05-20 19:52:55 EDT
qt-4.5.1-10.fc11, kdelibs-4.2.3-3.fc11, kdeplasma-addons-4.2.3-2.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update qt kdelibs kdeplasma-addons'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-4813
Comment 8 Fedora Update System 2009-05-25 17:17:22 EDT
kdelibs-4.2.3-3.fc11, kdeplasma-addons-4.2.3-2.fc11, qt-4.5.1-11.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kdelibs kdeplasma-addons qt'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-4813
Comment 9 Fedora Update System 2009-06-02 10:37:12 EDT
kdelibs-4.2.3-3.fc11, kdeplasma-addons-4.2.3-2.fc11, qt-4.5.1-13.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kdelibs kdeplasma-addons qt'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-4813
Comment 10 Bug Zapper 2009-06-09 10:34:58 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 11 Fedora Update System 2009-06-15 21:35:16 EDT
kdelibs-4.2.3-3.fc11, kdeplasma-addons-4.2.3-2.fc11, qt-4.5.1-13.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.