Bug 49766 - Selecting wrong mouse makes keyboard not work
Selecting wrong mouse makes keyboard not work
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-23 15:21 EDT by Anders Carlsson
Modified: 2007-04-18 12:35 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-26 21:46:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anders Carlsson 2001-07-23 15:21:56 EDT
During the installation I made a mistake and selected that my mouse was of
type PS/2 instead of USB which is the correct type. 

When I later started X the mouse wouldn't work, nothing strange about that
since I chose the wrong type. What's strange is that the keyboard didn't work.

I rebooted and ran XConfigurator, and when XConfigurator starts X to check
the configuration I got the same thing. Neither the mouse nor the keyboard
worked. When X exited and I got back to XConfigurator I found that the
keyboard didn't work even _after_ X exited.

Seems like X is trying to detect the PS/2 mouse and screws up the keyboard
by sending some weird data to it or something.
Comment 1 Glen Foster 2001-07-23 17:18:28 EDT
This defect is considered SHOULD-FIX for Fairfax.
Comment 2 Mike A. Harris 2001-07-26 21:46:49 EDT
What mouse (brand/model) do you have?  Also, what keyboard do you have?
Is your keyboard PS/2, AT, or USB?

This problem is sufficiently bizarre IMHO that I need much more detailed
information.  Can you create an X server log by running X configurator,
and then attaching /var/log/XFree*.log (all of em) to this report?

Please attach your configuration file as well, and a copy of your
/var/log/messages (trimmed if necessary to be <= 200k or so, we just
want the bottom of it preferably with kernel boot messages).

Also, are you using a Red Hat binary kernel, or a home built kernel?

Comment 3 Mike A. Harris 2001-09-02 00:58:43 EDT
Closing bug due to lack of information.

Note You need to log in before you can comment on or make changes to this bug.