Bug 497703 - bluez requires pulseaudio
bluez requires pulseaudio
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gnome-bluetooth (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-26 07:48 EDT by David Woodhouse
Modified: 2009-04-26 18:38 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-26 16:32:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Woodhouse 2009-04-26 07:48:49 EDT
I should be able to remove pulseaudio from the system, without also removing bluez. This was possible in F-10, and in fact it was the only way I found to make audio work reliably. It should also be possible in F-11, without removing all Bluetooth functionality.

But...

# yum remove pulseaudio
Loaded plugins: dellsysidplugin2, refresh-packagekit
Setting up Remove Process
Resolving Dependencies
--> Running transaction check
---> Package pulseaudio.x86_64 0:0.9.15-11.fc11 set to be erased
--> Processing Dependency: libprotocol-native.so()(64bit) for package: pulseaudio-module-x11
--> Processing Dependency: libpulsecore-0.9.15.so()(64bit) for package: pulseaudio-module-x11
--> Processing Dependency: libpulsecore-0.9.15.so()(64bit) for package: pulseaudio-module-gconf
--> Processing Dependency: libpulsecore-0.9.15.so()(64bit) for package: pulseaudio-module-bluetooth
--> Processing Dependency: pulseaudio = 0.9.15-11.fc11 for package: pulseaudio-esound-compat
--> Processing Dependency: pulseaudio = 0.9.15-11.fc11 for package: pulseaudio-module-gconf
--> Processing Dependency: pulseaudio = 0.9.15-11.fc11 for package: pulseaudio-module-bluetooth
--> Processing Dependency: pulseaudio = 0.9.15-11.fc11 for package: pulseaudio-module-x11
--> Processing Dependency: pulseaudio for package: alsa-plugins-pulseaudio
--> Processing Dependency: pulseaudio for package: alsa-plugins-pulseaudio
--> Running transaction check
---> Package alsa-plugins-pulseaudio.i586 0:1.0.18-3.fc11 set to be erased
---> Package alsa-plugins-pulseaudio.x86_64 0:1.0.18-3.fc11 set to be erased
---> Package pulseaudio-esound-compat.x86_64 0:0.9.15-11.fc11 set to be erased
---> Package pulseaudio-module-bluetooth.x86_64 0:0.9.15-11.fc11 set to be erased
--> Processing Dependency: pulseaudio-module-bluetooth for package: gnome-bluetooth
---> Package pulseaudio-module-gconf.x86_64 0:0.9.15-11.fc11 set to be erased
---> Package pulseaudio-module-x11.x86_64 0:0.9.15-11.fc11 set to be erased
--> Running transaction check
---> Package gnome-bluetooth.x86_64 0:2.27.4-3.fc11 set to be erased
--> Processing Dependency: dbus-bluez-pin-helper for package: bluez
--> Processing Dependency: gnome-bluetooth = 2.27.4-3.fc11 for package: gnome-bluetooth-libs
--> Running transaction check
---> Package bluez.x86_64 0:4.37-1.fc11 set to be erased
---> Package gnome-bluetooth-libs.x86_64 0:2.27.4-3.fc11 set to be erased
--> Processing Dependency: libgnome-bluetooth.so.2()(64bit) for package: gnome-phone-manager
--> Running transaction check
---> Package gnome-phone-manager.x86_64 0:0.65-1.fc11 set to be erased
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package                        Arch      Version            Repository    Size
================================================================================
Removing:
 pulseaudio                     x86_64    0.9.15-11.fc11     installed    1.9 M
Removing for dependencies:
 alsa-plugins-pulseaudio        i586      1.0.18-3.fc11      installed     88 k
 alsa-plugins-pulseaudio        x86_64    1.0.18-3.fc11      installed     95 k
 bluez                          x86_64    4.37-1.fc11        installed    1.1 M
 gnome-bluetooth                x86_64    2.27.4-3.fc11      installed    781 k
 gnome-bluetooth-libs           x86_64    2.27.4-3.fc11      installed     90 k
 gnome-phone-manager            x86_64    0.65-1.fc11        installed    553 k
 pulseaudio-esound-compat       x86_64    0.9.15-11.fc11     installed    3.2 k
 pulseaudio-module-bluetooth    x86_64    0.9.15-11.fc11     installed    208 k
 pulseaudio-module-gconf        x86_64    0.9.15-11.fc11     installed     22 k
 pulseaudio-module-x11          x86_64    0.9.15-11.fc11     installed     49 k

Transaction Summary
================================================================================
Install      0 Package(s)         
Update       0 Package(s)         
Remove      11 Package(s)         

Is this ok [y/N]:
Comment 1 Bastien Nocera 2009-04-26 08:18:39 EDT
pulseaudio-module-bluetooth is required by gnome-bluetooth, so that speakers and headsets work out of the box. So by removing pulseaudio, you're removing gnome-bluetooth, thus removing the only pin helper.

Install another pinhelper, and you should be able to remove pulseaudio.
Comment 2 David Woodhouse 2009-04-26 09:59:02 EDT
You've just rephrased the bug.

The problem is that we _want_ the pin-helper to remain, but need to be able to remove pulseaudio from the system.

If we want pulseaudio-module-bluetooth to be installed out of the box, we need to find a better way of doing it. Can we make pulseaudio require it? Or have the tools use PackageKit to ensure that it's installed when we actually set up a device which would use it?

Reopening.
Comment 3 Bastien Nocera 2009-04-26 16:32:06 EDT
(In reply to comment #2)
> You've just rephrased the bug.
> 
> The problem is that we _want_ the pin-helper to remain, but need to be able to
> remove pulseaudio from the system.

Then install another pinhelper.

> If we want pulseaudio-module-bluetooth to be installed out of the box, we need
> to find a better way of doing it. Can we make pulseaudio require it? Or have
> the tools use PackageKit to ensure that it's installed when we actually set up
> a device which would use it?

That sounds like a problem looking for a solution. gnome-bluetooth needs to have the pulseaudio-module-bluetooth package install to do anything with audio headsets. If you're not happy about it, feel free to take over the bluez-gnome maintenance.
Comment 4 David Woodhouse 2009-04-26 17:33:14 EDT
Er, we _had_ another pinhelper, in the bluez-gnome package. You obsoleted that without actually deprecating it so it disappeared from the media, and then you made its replacement require PulseAudio!

It is important that users be able to remove PulseAudio. Doing so was the only way that a number of people could make audio work reliably in F-10, and it's looking like the same will be true in F-11. But 10 days ago, after the final freeze for F-11, you suddenly made that impossible; at least for any GNOME user who needs Bluetooth.

That's not acceptable -- and it's especially unacceptable that you're refusing to even discuss alternative approaches to the problem you were trying to solve when you did that. I expect better from you, Bastien.
Comment 5 Bastien Nocera 2009-04-26 18:38:00 EDT
(In reply to comment #4)
> Er, we _had_ another pinhelper, in the bluez-gnome package. You obsoleted that
> without actually deprecating it so it disappeared from the media, and then you
> made its replacement require PulseAudio!

bluez-gnome isn't removed from the tree, and it's not a dead package. It still contains the analyser, which could be of some use. It's ready to be picked up.

> It is important that users be able to remove PulseAudio. Doing so was the only
> way that a number of people could make audio work reliably in F-10, and it's
> looking like the same will be true in F-11. But 10 days ago, after the final
> freeze for F-11, you suddenly made that impossible; at least for any GNOME user
> who needs Bluetooth.

I made it impossible because I wanted to have Bluetooth audio actually working for people without dropping to the command-line, having to setup funky alsa config files, or give weird options to their audio tools.

> That's not acceptable -- and it's especially unacceptable that you're refusing
> to even discuss alternative approaches to the problem you were trying to solve
> when you did that. I expect better from you, Bastien.  

If you feel that I've made any mistakes handling the bluez-gnome -> gnome-bluetooth transition, feel free to complain about it after you've taken over bluez-gnome and its bugs. In the meanwhile, gnome-bluetooth needs the PulseAudio Bluetooth module to have working Bluetooth audio (which is presented in the UI). I don't see how that makes it harder for anyone to use.

Note that in the future, it will probably also require the control-center package as we make it possible to call the mouse/keyboard prefs from the applet for those types of devices. And I'm sure other dependencies will come.

If there are PulseAudio bugs, I'm sure they'll get filed as bugs. If you have spec file bugs you'd like inspected, file them. But if the request is to remove the pulseaudio-module-bluetooth, then you'll already know my answer.

Note You need to log in before you can comment on or make changes to this bug.